This almost seems like a silly question, and yet I can't find the combination to keep the safe open.

I am trying to create a fileshare on a Windows 7 Pro workstation. I want NO authentication prompts. None! Zero! Zilch! :-)

The workstation is joined to a Windows domain. The share is "Scans" and the directory is C:\Scans

Despite my attempts at setting both Share and NTFS permissions and Everyone/FC, users connecting from other workstations are still prompted for credentials. What's worse is my network scanner can't send files to the share because of the need to authenticate.

The connecting workstations mostly run Windows 7. There might be a XP in there somewhere, but I don't know offhand.

Anyone run into this little oddity?


  • 2
    have you tried adding the user "Anonymous logon" to the share with the permissions you want? – brusilva Mar 16 '12 at 17:54
  • In this case, that did not work. :-( – tcv Mar 20 '12 at 19:52

I ran into this same problem just now and the help button on the share dialog actually (lo and behold) gave useful information:

Go to Control Panel -> Network and Internet -> Network and Sharing Center -> Advanced sharing settings and change Password protected sharing to off. See picture below:

How to enable passwordless sharing in Windows 7

| improve this answer | |
  • This is not secure and enables local Guest account. So any user can login using Guest account locally. – Maxim Sep 21 '16 at 16:23

In the startmenu type secpol.msc, this will open the local security policy manager. Go to Security Settings -> Local Polices -> Security Options in there select Network access: Let Everyone permissions apply to anonymous users and set it to enabled. Then add the name of each share to be accessed anonymously on a line by itself in the setting named 'Network access: Shares that can be accessed anonymously'. Finally, make sure the Everyone group has permissions on your share and you should be good to go.

Caveat: You are on a domain, if the domain group policy assigns a value to this setting you will not be able to override it locally without the domain admin making a change to the GPO putting in a exception for your computer..

P.S.: Since you are on a domain, you may be able to do this by giving Domain Users permission to read/write to the folder, then anyone logged in to the same domain as you should have access. However this will not likely fix your network scanner issue.

| improve this answer | |
  • Hi Scott, thanks for your help. I'm afraid I gave you wrong information. The workstation is not domain joined. I thought it was. So, the workstation sharing and the workstation accessing are NOT domain workstations. Sorry for the confusion. With that information, however, I was able to test the changes above and am still baffled. I got it to work, but I found that the Local Security option mentioned above had no effect despite the fact that "Everyone" did have Share and NTFS permissions. I found that enabling both Public Sharing and turning Password Protection off worked. – tcv Mar 20 '12 at 17:37
  • Having said all that, I am very perplexed why your suggestion didn't work. I tried again on a test environment, completely different workstations and different network environment. Same results. What's also perplexing is that if I REVOKE either Public Sharing or REENABLE Password Protection then share access is not immediately revoked. Maybe it would be after a reboot. – tcv Mar 20 '12 at 17:40
  • You probably also need to add your share under the setting 'Network access: Shares that can be accessed anonymously' – redcalx May 28 '13 at 15:58

I had the same problem between computers in my network - shares kept asking for a password.

It turned out that it was caused by having same usernames / different passwords between workgroup computers.

So anyone can access shares but if you have the same username / different password - you're screwed.

| improve this answer | |

Microsoft uses different permissions for share access and filesystem access. Make sure that the folder you're sharing and the share pointing to that folder are both set to Everyone/Full Control.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.