I just bought a new config ( ASUS p8z68-v lx, i5-2500k + ram and new graphic card ). Coming back and installing it in my old computer, I just saw that my DVD player was on IDE (yup…).

So, I needed to install windows 7 64bits from my usb key. Fine, I made my usb key bootable and copy the official DVD on it (the same version that was on my old computer), set BIOS to boot on it first and started the computer up.

It worked fine until it asks me for cd/dvd drivers (which is funny since, I do it via USB because I can't plug in my DVD player :D) I have 3 SATA HDD plugged in and that's it.

I made a small google search and found that it could be SATA or RAID drivers. Fine, I took another USB KEY and put all my motherboard drivers on it (from the CD sold with the MB) and none of those drivers seemed to work. I tried downloading new drivers from ASUS website and same effect.

Any idea but no "buy a new DVD player", I'm now broke for the month :) ?

  • What device does it want drivers for exactly? There is nothing "special" about a driver cd. What exactly is wrong with a IDE DVD...the current Intel Series 6 motherboards to my knowlege all have an ide controller.
    – Ramhound
    Mar 16, 2012 at 18:02
  • It's not clear why you couldn't install from the DVD. Does your motherboard not have an IDE port? Mar 16, 2012 at 18:05
  • @DavidSchwartz nope it does not have one usa.asus.com/Motherboards/Intel_Socket_1155/P8Z68V_LX/… !
    – HackToHell
    Mar 17, 2012 at 5:04
  • @Ramhound no IDE port; so no old DVD player like mine, so no installation from DVD… It says "cd/dvd player driver is missing" with no more information… But I agree with you, there's nothing special about a cd driver…
    – Shikiryu
    Mar 17, 2012 at 8:47
  • It worked fine until it asks me - i dont get it - so did you install windows or not? The thing that you boot from usb have nothing to do with 'usb driver' for computer its just a boot media. Tell me exactly on which step of instalation you stack in. Mar 19, 2012 at 16:17

15 Answers 15


You need USB 3.0 drivers to read installation media. Windows 7 is fine with AHCI.

  • 3
    Why USB 3.0 drivers? Why AHCI? I don't get you, have you read anything in this question? Mar 20, 2012 at 16:17
  • 2
    because you have USB3.0 controller. Even it is electrically and programmatically compatible with USB2.0 windows will see USB device generation 3 and default driver will not install....
    – ZaB
    Mar 21, 2012 at 13:38
  • But it booted from USB 3.0, so it should have access? Mar 21, 2012 at 13:41
  • 1
    I have read reports of USB 3.0 ports causing problems with W7 install due to missing 3.0 drivers, nothing I can verify though....h30434.www3.hp.com/t5/Other-Notebook-PC-Questions/…
    – Moab
    Mar 25, 2012 at 2:36
  • 4
    Oddly (because it's been downvoted twice), this answer is the closest one that saved me :) Reading it made me realize that I may have been using one of the two USB3 port for the USB key having windows setup… I checked my MB manual and got it. I changed for a USB2 port and worked :) Anyway, I tried every drivers from my MB DVD before, including USB3… I guess installing an updated USB3 drivers (which I didn't think of) could have worked but found it easier to change to USB2 ;) .
    – Shikiryu
    Mar 25, 2012 at 15:45

The problem is a bit mysterious until you realize what's happening behind the scenes during a windows install. And, there is a workaround to allow you to use USB 3.0. One workaround is easier in the moment, the other requires a bit of work to setup, but will be easiest for future installs.

Introduction: What exactly is the problem

Here is a lengthy but casual description of the process, and why you can't complete the install:

  1. Bios starts the computer. Bios is software. It runs the POST - and loads basic support for various hardware devices. It is able to access the USB 3.0 ports, it finds the boot manager on the USB stick, and the bootmgr loads the windows 7 installation setup.

  2. Once the windows 7 setup exe loads - bios hands over control of the hardware. The bios access to hardware ends. Windows Setup must load it's own drivers to see the various hardware devices. I think this is called the Windows Pre-Installation Environment. It doesn't have USB 3.0 drivers. So no, just because you started with access doesn't mean you still should now. You don't.

    You may be aware that during this installation process, WinPE can see some hard disk controllers. Back in the day (win NT 4.0, 98 etc) it could see IDE controllers, but not SATA, or 3rd party, or many SCSI controllers. If you had a new motherboard, or add in card - you would have to press F6 and put a floppy disc in. WinPE would load drivers from the floppy, and then it could see the SATA controller, or scsi device, and installation to the disk on that new controller could then continue. The problem here is similar...

    Further Detail: While bios is accessing the USB 3.0 memory stick, WinPE creates a virtual hard drive, called, Drive X: and WinPE loads itself onto Drive X. Bios then hands over control, and WinPE examines drive X for inf files, to load any drivers it needs. For Windows 7, it has SATA, and USB 2.0 - but it does not have USB 3.0 drivers in it's arsenal. (Remember, Win98 didn't have USB 2.0 drivers either).

    So, why can't you continue? The problem is, only the WinPE environment and utilities (eg: the partitioning utility) are loaded onto Drive X. The actual windows 7 software is still stored as a package on the USB 3.0 memory stick - and now that bios has handed over hardware control to PE, you've lost access to it. We'll fix that Later...

    The last step in the process...

  3. NORMALLY, after WinPE unpackages the Win 7 files onto your hard drive, and reboots - (you might already realize this) - the Pre-Installation Environment evaporates. It was only stored on a virtual drive "X:" and since ram is erased on reboot - so was WinPE. So, you guessed it, Windows 7 would now be on your pc, and again, doesn't have access to USB 3.0.


So now, it should finally make sense, that Bios, Windows Preinstallation Environment, and Windows 7 are each their own operating systems, each more complex than the one before - but each needs it's own drivers to access devices.

The Solution:

It's actually pretty simple. You just need to add a driver to each OS. Bios has it's own. Windows PE and Windows 7 are stored as packages on the installation disc.

The long way around is to get a copy of your USB 3.0 drivers, and unpack the WinPE package, and if you want, unpack the Windows 7 package, stick the driver INF files into their driver caches, and repackage them, and put the updated package back on the install disc. Once that's done, you're good for any new installs you do. Someone else can tell you how to slipstream. It's a bit time consuming for a one time fix.

For a one off, it's a lot easier to do this.

Remember that a USB stick will only install Windows 7 if the stick is formatted NTFS before you copy your Win7 dvd to it. FAT wont work.

  1. Locate your USB 3.0 drivers for windows 7 (x32 or x64, I'm not sure how crucial that is). For myself, I used an Etron 168 and there was just one INF and it worked for x64. On a Win 7 x64 installation, there are both x32 and x64 drivers present, so start by matching the corresponding driver to the install you're working with. If that doesn't work, maybe try the other.

  2. Create a drivers folder on the USB stick, or on a second USB stick.

  3. Boot from the USB 3.0 port.

    (Misc notes: bios must be set to boot from a "USB-HDD" for this, and some mobo's are fussy - e.g.: Gigabyte - and some will default to the ssd or hdd anyway if it is bootable. )

    Win PE will load (very quickly, by the way), and will complain, The error is something about the CD/DVD drivers are needed. (note: CD/DVD, not a hard drive or scsi driver!)

  4. At this point, you have the option to Browse. Whichever USB stick you put the drivers onto - put it into a USB 2.0 port, and THEN browse. WinPE will autodetect the USB 2.0 stick, you can browse to the folder, and select OK. WinPE will load the USB 3.0 drivers.

    (REMEMBER - these drivers are for WinPE, and once it reboots, they will be lost.)

    Caveat: Because you've just accessed a USB 2.0 port, WinPE may want to locate any further files from that USB 2.0 port. After the USB 3.0 driver is loaded, REMOVE any stick from the USB 2.0 port, and ensure the USB 3.0 stick is in the USB 3.0 port. WinPE might error at this point, and it may appear to revert 1 step back. As long as the USB driver loaded, you will be able to move forward. It's for this reason, that if you do multiple installs, slipstreaming your driver into the WinPE package might be easier. Again, look elsewhere for how to do that.

  5. Ideally, once the driver loads, WinPE will move to the next step, and you can now start your install. Select or create the partition on your hard disk (or SSD), and start the install. With your USB 3.0 drivers working, WinPE will be able to locate the Windows 7 package on the USB 3.0 stick, and unpack it into the hard disk partition you selected.

    Note: It may not make sense, but WinPE could have seen, and allowed you to tailor the Hard disk or SSD, created and sized your partitions, and THEN complained it didn't have access to the Windows 7 package on the USB 3.0 stick - but for whatever reason, it stops things right up front, and asks for the CD/DVD driver (in this case, usb 3.0 driver).

    The install will be very quick from that point. For a build I just did, it unpacked Win7 onto a low end ssd in 4 minutes.

    At that point, it will advise it wants to restart the pc. Once the pc reboots, the install will continue exclusively using the files now on the hard disk /ssd.

  6. Therefore, remember to remove the USB stick during the reboot.

  7. Make sure bios is configured to boot from the C: drive (hard disk/ ssd) at this point.

    Windows 7 will configure itself, load any device drivers it can, and you'll be at the desktop in no time.

  8. Just remember you now need to put the memory stick in a USB 2.0 port and load the USB 3.0 drivers for Windows 7!

  • 1
    As noted in this section of the FAQ, all of the user generated content on this site is licensed under CC BY-SA 3.0. Attribution is already required.
    – JoshP
    Sep 24, 2012 at 19:51
  • 1
    I've made some major formatting changes to your answer to make it a bit more readable. Feel free to rollback/alter these changes as you see fit. Sep 27, 2012 at 18:34
  • I am going to downvote for the simple fact the user wanted money for free information.
    – Ramhound
    Oct 4, 2012 at 17:58
  • Intel now ships a utiliity that will patch the ISO install image after you have loaded onto a USB drive. This utility will add USB3.0 support to the installer image. It is advertised for use on the Intel NUC, but I have successfully used it on other boards. downloadcenter.intel.com/download/25476/…
    – Daniel
    Jun 10, 2016 at 15:27
  • "Intel now ships a utiliity that will patch the ISO install image" - only if you're installing 64-bit. For 32-bit, the dismgui instructions in their readme works, and the instructions at Dell work. I've seen others that don't work.
    – EML
    Apr 7, 2018 at 12:23

Try this, ymmv.

Install from USB:

When Windows is asking for driver, just click Cancel. You will be brought back to the welcome screen. At the welcome screen, remove your USB drive, insert it back to DIFFERENT USB PORT. Click Install Now again. The installation process will be like usual.

Also, forget where I found this tidbit

"it was the SATA drivers for the MoBo"

"On another PC (obviously), I downloaded the latest Win7 drivers for my motherboard and put them on the USB stick that I was installing Win7 from (although this should probably work even if you install from DVD, just as long as you can get to them when you Browse from the error dialog). Once I got the error, I browsed to the files to install, but they still didn't show up. I unchecked the box for not displaying incompatible drivers and then they showed up. I selected the driver and hit Next and everything went smoothly after that."

"What drives me crazy is that the error message gets you looking for DVD drivers when it has nothing to do with that, plus Win7 doesn't even recognize the correct drivers as being compatible with the hardware!"

  • @Shikiryu: Does the above work? Mar 20, 2012 at 16:14
  • 1
    Unfortunately not. Cancel and redo just did the same thing twice (obviously). As I said, I already tried every SATA drivers from my MB DVD (transfered on another USB key) and from Internet...
    – Shikiryu
    Mar 25, 2012 at 15:39
  • Crazy sh*t Oo, works for me, too. :)
    – CSchulz
    Apr 22, 2013 at 16:29

OK, on short you must change the USB port. I nearly thought I wrecked a friends LAPTOP.

My problem was like this:

  • ASUS laptop
  • no physical DVD drive
  • WIN7 was asking for CD/DVD driver

As soon as I changed the USB port from 3.0 to another one (which I suppose was a 2.0 drive) it worked.

  • Exactly what I explained here . Thanks anyway :)
    – Shikiryu
    Sep 24, 2012 at 15:33
  • I had the exact same issue. After switching my USB installation media to a different (USB2.0 vs. USB3.0) port, worked fine.
    – Rob3C
    Jan 26, 2013 at 20:08
  • Had this issue reinstalling my Dell XPS13. Plugged boot flash drive into USB3 port. Plugging it into the USB2 port sorted it, no restart needed
    – Dan J
    Jan 6, 2014 at 23:13

I had this issue with an ASUS N56VZ laptop, which only has USB 3.0 ports (Intel chipset).

I went to ASUS's driver downloads for my laptop model, and found that 2 drivers in particular were necessary for success on my laptop: the Intel Chipset drivers (for USB 3.0 support), and the Intel RST drivers (Rapid Storage Technology). Note that you may not need the RST drivers if you have the RAID controller fully disabled (and only use AHCI mode).

Once I downloaded the drivers, I extracted the archives, and copied them both into the sources folder on the USB. Finally, I rebooted from USB stick in same USB port, and voila! Install as per the usual process.

P.S. It shouldn't make a difference, but just note that both my USB stick and ports are both USB 3.0.


Normally you would need the AHCI/RAID drivers, wich can be made using this driver package: http://dlcdnet.asus.com/pub/ASUS/misc/sata/Intel_AHCI_RAID_V10501026_XPVistaWin7.zip

According to the description: "Make Intel AHCI/RAID Driver Disk". That is what setup needs to access the harddisks.

Officially the files in 'Intel_AHCI_RAID_V10501026_XPVistaWin7\Driver\64bit' should be what you need.

Alternatively you can recreate the USB stick using the official method that's suppored by Microsoft: http://www.microsoftstore.com/store/msstore/html/pbPage.Help_Win7_usbdvd_dwnTool

Good luck!

  • 2
    That's everything I tried so far before posting here… without success.
    – Shikiryu
    Mar 19, 2012 at 20:42

Have you tried this: When setup asks for drivers close these two dialog windows until you are back on welcome screen and then change USB port (attach flash drive with Win7 setup to another port) and click "install now" again? It is much simpler.

  • This only works if you reconnect to a non 3.0 USB port.
    – user148298
    Jun 13, 2013 at 23:03

Found another possibility in this thread :

I've since found the problem lies with the win 7 SP1 download. I've downloaded the original Win 7 non SP1 file from Technet downloads and it installs ok, it doesn't ask for a CD/DVD driver...

  • 1
    Thanks, but I have an official Windows 7 64bits DVD. I didn't download it ; no SP1 here then ;-)
    – Shikiryu
    Mar 19, 2012 at 20:44

Here's the easiest solution to the problem without the hassles of locating the correct driver. This issue happens only with the latest builds of windows 7 installer running from a USB drive connected to a USB 3.0 port (usually blue colored). Simply reconnect your USB drive to a non-3.0 port and restart the installer by clicking the close button on the setup window and trying again. Most newer motherboards have both ports.


Apparently Windows 7 has no built-in USB3 drivers (source) (unlike Win8 or 8.1) so after the control is passed from the BIOS (which does know its USB3 controller well enough) to Win7(PE), the OS looks for appropriate drivers to load for the controller onto its driver stack, but it fails to find any. So every port connected to a USB3 controller won't work without additional drivers. Also, I think all blue-ish ports are USB3.

Some BIOSes may allow downgrading the USB controller's mode for backwards compatibility, which can solve the problem in some cases, by forcing the controller to work in USB2 mode through the BIOS settings.

The seemingly easy solution is to find the appropriate drivers and supply them to Win7. They can usually be found somewhere around Support->Drivers-><OS>->USB in the motherboard manufacturer website, where <OS> is to be replaced with sth like "Windows 7 64-bit" in this case. It should be noted that the files may need to be unpacked beforehand, for the OS to recognize them. The folder containing the .inf (a.k.a. "setup information") file(s) for the appropriate architecture (amd64 in this case) needs to be made available to the OS.

In this particular case the following steps may work (links might become invalid, ...):

  1. Download this and unpack it,
  2. Copy the folder "Driver" to the USB memory,
  3. Once asked for the driver files, select the folder "Driver" or the file "asmthub3.inf" inside it.

Make sure your USB is not in a USB 3.0 port. Disable XHCI Pre-Boot Mode in BIOS. This will disable the USB 3.0 port so the Windows Installation doesn't see it, and therefore doesn't require drivers for it.


Since Windows 7 won't load unsigned drivers by default, you need to press F8 when the DVD PE-OS is booting and select Advanced Boot Options, then choose Disable Driver Signature Enforcement. This should solve the issue if the other method didn't work.

I burned the ISO from one of the USB drives to a DVD and was able to install Windows just fine with it.

  • This sounds more like a comment rather than an answer.
    – Darius
    Oct 4, 2012 at 17:47
  • Until I am able to try the F8 workaround myself, I would say it's more of a suggestion. I will update once I am able to try it out and confirm that it works.
    – Eric
    Oct 4, 2012 at 21:16
  • I tried this and it didn't work for me. So I tried this and then cancelled the installation and move the usb to another usb (2.0) port but that didn't work either.
    – bgmCoder
    Jul 24, 2015 at 16:16

I know this is an old post, but I found this via Google and want to share what fixed it for me.

I booted from a USB 2.0 flash drive (on a USB 2.0 port) and when it prompted for drivers, I canceled and went back to the "Install now" prompt in the installer.
Then I removed my flash drive, plugged it into another computer, and changed the UUID and unset the boot flag with GParted. Then I plugged it into the new computer and retried installing, and it worked!


I was having this error when trying to install Windows 7 off an old USB stick.

Nowadays laptops often don't have USB 2.0 ports.. so you might not have that option. And simply plugging an external one into a USB3 port probably won't help you in this case!

If you have a CD/DVD then some suggest using that, though often laptops don't have those built in.

A common suggestion is to slipstream USB3 drivers in. I saw a guy doing it in a youtube video (that i'll mention), and he used this article http://codeabitwiser.com/2014/03/how-to-install-windows-7-with-only-usb-3-0-ports/ and it shows steps e.g. "get the usb3 drivers," and further steps. A Windows 7 ISO has two important files, boot.wim and install.wim and these are compressed files that can be opened/looked at in a program like 7-zip. The file install.wim has some folders named like 1,2,3 that each have the directory structure of a fresh windows installation. There is a command called DISM that can be used to "mount" a WIM file to a directory, so you can add/remove files. And there is also a command to automatically add USB drivers to an ISO (once you've downloaded the drivers). This video titled "Adding USB3.0 Drivers to Windows 7 Pro Boot Drive" by "AnCrypthony M" https://www.youtube.com/watch?v=kgF6FUeKCqQ has him going through the article in that link. One issue he didn't mention 'cos he didn't run into, is that you might get an error with the DISM command to install USB drivers https://www.sevenforums.com/drivers/394090-cant-slipstream-usb-3-0-drivers-windows-7-a.html and have to "unblock" the file(sometimes files downloaded need that, it's an option in the properties of the file in windows). Perhaps you can also copy the USB related files to a directory on the media and then browse to it.

Personally, I found my ISO en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso worked fine. (Whereas the USB stick win7 media even when slipstreamed, gave that error, which was strange. And on further investigation it had some qualities that looked like it wasn't 64bit e.g. no "programs files (x86)" directory in the install.wim). So you could try a fresh ISO like the one I mention there that worked for me! Otherwise, a USB2.0 port, otherwise, slipstreaming the USB drivers in.

And there's also a tool from gigabyte, that might make it easy to make a windows 7 ISO slipstreamed with USB3 drivers https://www.cybernetman.com/kb/article/how-to-slipstream-usb-3-0-drivers-into-windows-7-installation-media


I had this problem as well a while back and if I recall correctly I simply tried another USB-port and it worked. It is also very important that you make the Windows 7 USB installer following these steps: http://www.intowindows.com/how-to-install-windows-7vista-from-usb-drive-detailed-100-working-guide/

(I'm not promoting any site here, there are several guides like this one and I just picked one of many)

  • See my answer. It has to be a 2.0 port.
    – user148298
    Jun 13, 2013 at 23:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .