I have a Shuttle Intel G31 + ICH7 (base -- not M/R etc) system. I just bought an OCZ Vertex 3 120gb [VTX3-25SAT3-120G] which includes the Sandforce 2218 firmware.

The ICH7 does not support AHCI. I understand that this can be a problem. What I don't understand, is if it's necessary to have the proper performance of this drive. I know that without AHCI I may get a limited read/write speed -- this is fine. What my concern is, is the constant freezing/hangs I'm getting with Windows 7 on any disk activity. The 'Highest Active Time' flip-flops from 0 to 100% every minute or so regardless of large or small files.

EDIT: The threads/processes with the highest response time is the kernel.

I've been reading about other people with Shuttle SG31G2s, and they seem to be using SSDs no problem. Is this the controller's fault? The fact that I do not have AHCI enabled? It makes sense to me that if this SSD requires AHCI features that it would cause Windows to hang, but I would like to fully determine my situation before returning things/reformatting.

To initially have my drive recognise the SSD at all, I had to change the BIOS option to Force Gen II instead of Auto for the SATA controller. I then installed Windows with no problem. There were no errors in the event log related to disk usage, but watching the perfmon I could see the highest active time and the processes (usually pagefile.sys being written to, or chrome/firefox caching) which was correlated to the hanging.

So now what I need answered is: should I be returning this SSD and getting one with a different controller, or returning the SSD all-together as it will never work out and I will continue to get these hangs.

Posts I've read:

Windows 7 New SSD SATA AHCI? -- suggests to use AHCI

http://forums.anandtech.com/showthread.php?t=2189868 -- Sandforce issues

Windows 7 freezes with SSD -- and attached posts

Why does my Windows 7 PC / SSD drive keep freezing? -- this is not the controller I have, but still a related issue.

Windows 7 hangs after longer inactivity of user -- also tried messing with power settings with no luck. It was already set to 'Never' for turning off HDDs.

  • What cable are you using the connect the SSD to the board? – David Schwartz Mar 18 '12 at 20:30
  • The cable just says "SATA" on it. Do they make cables specifically for SATA2/SATA3? – h4xnoodle Mar 18 '12 at 23:02
  • It sounds like you may not have a SATA cable that's rated for SATA-II. Cables can't negotiate, so they must support the highest mode both endpoints support. – David Schwartz Mar 18 '12 at 23:07
  • Not sure if you ever figured this out, but I finally solved a similar issue: superuser.com/a/428619/30828 – Mark Sowul May 26 '12 at 14:10

I had the same problem as you were having. It turned out to be Intel's Rapid Storage Technology software that caused the issue. As soon as I uninstalled it, everything went back to normal. The system would act and run fine, but every 10-15 minutes, it would come to a freeze for 30 seconds. As soon as 30 seconds passed, it was like nothing was wrong.

  • I don't have the Intel RPS stuff installed, so I don't think I have this issue. I'm glad it fixed yours, though :) – h4xnoodle Mar 18 '12 at 22:34

According to OCZ, it should work fine using IDE mode, I did find this, it could be a power issue, try a larger power supply.

enter image description here

Source of Information

  • I just went through this process and I don't think it made any difference with the SSD. What's worse, my install of Windows on the SSD is thoroughly damaged -- it believes that it is not genuine and is incredibly sluggish. It even BSOD'd just now. – h4xnoodle Mar 18 '12 at 23:37
  • You Might need a better power supply was my point, sorry I was not clear. – Moab Mar 19 '12 at 0:48

I had the same problem with the same drive, so I uninstalled 7-zip (if you have it) and disabled my antivirus while I was cutting and pasting, and it works perfectly now.

Might not be the same for you but it's worth a try and my SSD hasn't frozen since.

Also, my bios doesn't allow me to change to AHCI so I am running on an IDE system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.