I have a Samsung Galaxy S II, which when connected to my Windows 7 computer acts as a "Portable Media Player"

GT-I9100 Portable Media Player

Whenever I try to copy a video onto the device, it prompts if I want to convert it, like so:

Do you want to convert <video> before it's copied to your device?

This gets quite annoying in the long run, so I'd like to disable it.

Is there a way to disable these prompts?

  • 1
    I think what I did with my N8 was connect it in mass storage mode so Windows would treat it as a standard flash drive. For the SII try Applications > Development > USB debugging.
    – Bob
    Mar 18 '12 at 23:52
  • It is almost always faster and less problematic to connect these devices as "Mass Storage" if the syncing is not nessisary, When your just trying to copy files, and you know the files are formatted for the device.
    – Psycogeek
    Mar 19 '12 at 1:36
  • @Bob: I don't believe I can do that since I've switched to Android 4. USB debugging is enabled, but it doesn't put it into mass storage mode as it did in 2.3.5, and it only lets me pick one of "Media Device (MTP)" or "Camera (PTP)" for connection mode. Mar 21 '12 at 12:57
  • Answers below are outdated, because recent Android no longer supports Mass Storage mode. And it seems that those smart Microsoft engineers never expected that people would be annoyed when they have to deal with that unnecessary confirmation dialogue each time. Does anyone know any alternative MTP transfer application on Windows? Something similar to an FTP program but in MTP. May 7 '15 at 3:18

Why this happens

That prompt is one of the features Windows implements for devices connected as MTP devices. The most sure way to disable it is to connect your Galaxy SII in USB Mass Storage mode. This way, Windows will detect it as a normal flash drive and will transfer files like any other flash drive without caring about the type. Some (desired) more advanced functionality may be lost, however.

The two basic ways to stop this from happening:

  • Connect the phone in Mass Storage mode.

  • Disable the shell extension on Windows that handles this. There are two ways to do this:

    • Unregister the .dll.

    • Disable the extension with ShellExView.

Option 1: Changing the phone connection mode

Enabling Mass Storage mode on Galaxy SII ICS (Android 4.x) (source):

  1. Bring up Settings.
  2. Click More… (under Wireless and network).
  3. Then select USB utilities ~ Set USB cable connection mode.
  4. Select Connect storage to PC then.
  5. Connect USB cable from phone to PC.
  6. Select Turn on USB storage. That’s all.

Option 2: Unregistering the .dll for the Windows shell extension that handles this

If you wish to keep using MTP mode for whatever reason, there has been a thread created on microsoft Answers specifically addressing disabling this prompt. Specifically:

Well, I previously couldn't find references to that dialog in any Windows 7 DLL file, so I thought that it wasn't Windows-related. But I have now looked again and found references to it in wpdshext.dll. So it does appear to be a standard Windows feature, my apologies.

I suggest that you try unregistering the DLL in question. Please open the Start Menu, go to All Programs - Accessories, right-click Command Prompt, and select Run as administrator. Then type the following command:

regsvr32 /u wpdshext.dll

You should probably restart after running the command.

I have not tried this method personally, and unregistering standard Windows DLLs may have unexpected consequences. If anything does go wrong, I recommend you start in Safe Mode and run regsvr32 wpdshext.dll in an elevated command prompt.

Disabling the shell extension

This method may be safer than unregistering a .dll.

  1. Download ShellExView

  2. Find the extension named Portable Devices Menu

  3. Right click > Disable Selected Items

  4. Restart your computer (to be safe)

  • 1
    He didn't ask how to connect in MS mode, he asked how to disable the prompt.
    – Mark
    May 19 '12 at 15:01
  • 3
    @Mark Connecting in Mass Storage mode is a definite way to disable the prompt. In other words, he can transfer videos without the prompt, the desired result. This answers the question, albeit at the cost of other MTP functionality/advantages. I did mention that in the original answer. However, I did just dig up a source mentioning disabling the Convert dialog specifically while (presumably) keeping other MTP functionality, and have added that to the answer.
    – Bob
    May 19 '12 at 15:54
  • 5
    Now I can upvote your answer! Generally, the advantages of MTP (the major one being that the storage in question does not need to be unmounted from the device first) outweight the disadvantages. Only when the absolute highest speed is required is MS mode better.
    – Mark
    May 19 '12 at 17:11
  • 3
    I did disable the shell extension, but it did not remove the prompt either.
    – Ruud
    May 27 '12 at 10:38
  • 2
    None of these methods work
    – monstro
    Feb 14 '15 at 17:15

As nothing mentioned works for me on Windows 8.1, here's alternative approach using a script in AutoHotkey.

dlgTitle := "Copy"
dlgBtnUnwantedAction := "No, skip this file"
dlgBtnWantedAction := "Yes"
dlgTitleAlt := "Convert and Copy"
dlgBtnUnwantedActionAlt := "Yes, convert and copy (recommended)"
dlgBtnWantedActionAlt := "No, just copy"
dlgBtnCancel := "Cancel"
GroupAdd, dlgTitles, %dlgTitle% ahk_class #32770
GroupAdd, dlgTitles, %dlgTitleAlt% ahk_class #32770

SetTitleMatchMode 3
matchFound := false

    WinWait ahk_group dlgTitles
    matchFound := false

    ControlGetText, button1Text, Button1, ahk_group dlgTitles
    if ( button1Text = dlgBtnUnwantedAction || button1Text = dlgBtnUnwantedActionAlt ) {
        ControlGetText, button2Text, Button2, ahk_group dlgTitles
        if ( button2Text = dlgBtnWantedAction || button2Text = dlgBtnWantedActionAlt ) {
            ControlGetText, button3Text, Button3, ahk_group dlgTitles
            if ( button3Text = dlgBtnCancel ) {
                matchFound := true

    if ( matchFound ) {
        ControlClick, Button2, ahk_group dlgTitles
    } else {
        WinWaitClose ahk_group dlgTitles

Years later... there may be a way. Open regedit as administrator and head to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\

Backup this "FormatMap".

Next, we'll try to fool Windows... Basically, you'll have to copy the content of "Format" and "ContentType" keys from a format to another.

Try to use these source formats :

.gif, .bmp for images (jpeg, png...) :
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.gif]

.wma for audio (mp3,mp4, aac, flac...) :
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.wma]

.wmv for video (avi mp4...) :
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.wmv]

.doc, .xls, .ppt for documents or other files :
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.doc]

e.g., the original key for flac is

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.flac]

So we'll just change it to WMA's ID:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.flac]

We could also add new formats, like .m4a (audio mp4) :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\FormatMap\.m4a]

However, it may have unwanted effects on any app using theses keys... Maybe WMP ?

  • As you yourself said, it has unwanted effects. Definitely. You must not "fix" annoyance by making it a technical problem.
    – user477799
    May 1 '17 at 19:44
  • I haven't noticed unwanted effects (yet), but I don't use WMP to listen to music. Moreover, my phone isn't recognized by WMP, so I can't try the "sync" feature. I found out it works for file transfer, but I didn't do additional tests and my computer still runs fine. The only possible problems I can imagine are with WMP or the way Windows analyze media devices for autorun. Sometimes we have to choose between two annoyances... What were yours ?
    – clorydric
    May 2 '17 at 20:46

My solution was to just patch wpdshext.dll

On my system (Windows 7 x64, with WMP not installed) the function that opens the confirmation box is

long __cdecl CObjectPropertyChecker::_DoesObjectMatchDeviceCapabilities(int)

which returns 0 if the copy is allowed, otherwise 1.

I just replaced the first few bytes of the function with:

xor rax,rax

so it always returns 0.

Working well so far; I'll report back if I notice any unexpected results.

for reference, the CRC of my wpdshext.dll was d6ca5ac8, before patching

and _DoesObjectMatchDeviceCapabilities is at RVA 0x95118

  • Thanks. What's a good tool to do this? Alternatively, could you upload your patched file somewhere?
    – Denis Howe
    Sep 24 '19 at 7:44
  • i suggest x64dbg, since you can attach to explorer, go to SymbolsModule 'wpdshext.dll' → Download symbols …, which makes it easy to find the function to patch.
    – Cauterite
    Sep 24 '19 at 11:31

For those of you having trouble getting any of these technical suggestions to work (like me) I found a workaround. Just make a new folder on your PC desktop and copy into it all the files you want to transfer to your device. Then, once that is done, just drag the whole folder onto your device to copy it across as usual. The prompt will appear, but you can just select "do this for all files" and it will transfer across the entire contents of the folder without prompting you again.


Not the answer you're looking for? Browse other questions tagged or ask your own question.