I dual booted my xp, installing linux mint, My connection is so bad on my linux mint, but good on windows 7 and windows xp and on mobile.

speedtest.net results on my linux mint 12

Ping: 200ms
Download speed: 4.08 Mbps
Upload speed: 0.08 Mbps

All the websites are opening fast on my mint but some of them are not opening the right way, and some websites are not opening at all. I haven't been able to open SO this week. Now SO is opening as normal

This is how github is opening

enter image description here

This is how youtube is opening:

enter image description here

Do you know why I'm having this error? I don't have any antivirus, i am using default firewall settings, i have apache python django php ruby java and some stuff installed. But i don't think this is the cause.

I tried google chrome and firefox and this issue is on both browsers. I didn't have this issue last month. any guess? My isp cannot help me coz he's a windows guy and he's only responsible for fixing networking errors, not personal problems.

  • I tried deleting my cache and history, everything, didn't fix it :( – user Mar 18 '12 at 19:44
  • 4 days ago, i wasn't able to open google, now facebook don't open as it normally does, i can't download gems for my ror apps... please take a wild guess, just a wild wild guess on what may be causing the problem so i can fix it – user Mar 18 '12 at 20:07

Sounds like a DNS issue. What are your settings in /etc/resolv.conf?

Try using OpenDNS servers: and

| improve this answer | |
  • in my /etc/resolv.conf i see this: # Generated by NetworkManager nameserver – user Mar 18 '12 at 20:53
  • do i replace with and – user Mar 18 '12 at 20:55
  • Put each DNS server on a separate line. nameserver and nameserver – Matt Beckman Mar 18 '12 at 21:07
  • slightly slower than the normal dns, but WORKED!!! WOOOOOOOOOORKED! one more question, is there any limitations for open dns? bandwidth usage? speed limit? anything like that? – user Mar 18 '12 at 21:32
  • OpenDNS is one of many free public DNS services. I use it on a day-to-day basis. It's generally accepted that ISP DNS servers are not the most reliable systems in the world. – Matt Beckman Mar 18 '12 at 21:35

A wild guess why your github opens like that, maybe you have javascript disabled on your browser...maybe not because you tried two browsers...

check ping www.github.com, is there any packet loss. Run it for a long time, maybe 3-4 mins and see how many packets are lost.

check your drivers on Linux for the wireless device(if you are on wifi). I am not familiar with mint so cannot tell you exactly how to do that. Google for a right driver.

| improve this answer | |
  • javascript is enabled on google chrome and firefox, sorry for not mentioning that in my question :) – user Mar 18 '12 at 20:32
  • @user, yeah figured that as you are using two browsers, unlikely. But check my edited answer, hope something works out for you :) – Gaurav Sinha Mar 18 '12 at 20:35
  • how do i check the ping loss of a specific website? is there a tool or a web app for that? and yes, i am on wifi – user Mar 18 '12 at 20:58
  • i'm using pingtest and it says couldn't connect to the server, a firewall might be blocking it or the server might be having issues. Could it be a firewall problem? – user Mar 18 '12 at 21:03
  • @user sorry for late reply, but seems you got it working :) cool. – Gaurav Sinha Mar 18 '12 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.