5

I'm just editing .cs usual classes and my text cursor is often becoming usual cursor. This doesn't make VS useless, but is pissing me off.

There is some hock to restart the cursor without need to close and reopen VS?

I'm developing a MVC C#4 project if it helps.

Thanks in advance.

2
  • Could you provide a screenshot of this? Mar 20, 2012 at 18:37
  • Do you mean the cursor is changing from the vertical bar (which sits between two characters) to the block cursor (which covers a character). If that's the case, then you are pressing the Insert key and toggling between insert and over-type modes. Mar 21, 2012 at 0:50

4 Answers 4

4

I think I figured out what the problem is. When editing HTML with links on the page, pressing control and hovering over the links then going back makes the IBeam (text cursor) permanently disappear. Luckily this is on a per file basis so simply reloading the file will fix the problem. I wish there was some way of fixing it but I haven't yet found a way.

2

I was struggling with this too, until I saw Dave's answer; it ticked me off because it seemed like something I've seen before, so I looked into VS settings, and sure enough I found something that may help. It's not so much a fix as it's a workaround though:

  • On the menu, go into Tools / Options... ;
  • Navigate the settings tree to Text Editor / HTML ;
  • On the main / general node, on the "Display" section, uncheck "Enable single-cick URL Navigation".

Just for kicks, I did the same on the CSS and JScript nodes too, because that's not really a useful feature for me, so as far as I'm concerned, it works as a fix for me :-)

1
  • This tip was a lifesaver - thank you! ADDITIONAL NOTE: this stupid option isn't even visible unless you ALSO click Tools > Options > Show all Sets = Yes". THEN you can go back and set Tools > Options > Text Editor > HTML > Enable single-click URL navigation = "No". To get your missing cursor back ;)
    – paulsm4
    Jan 4, 2016 at 0:55
1

This happens to me too sometimes, but I've noticed it's on a per file basis. I've found that simply closing the offending tab and then reopening the file fixes it without having to restart VS, it's still annoying though. I've yet to discover a fix for it, or what causes it.

0

None of the (many across web) posted solutions for the disappearing cursor worked for me.

I found a solution that works for me: Tools/Options/Environment/General/Window layout ...there are 2 radio buttons:

  • Tabbed Documents
  • Multiple Documents ...you must select one or the other. I switched to 'Multiple Documents' and this solved the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.