1

Is it possible to setup a monospaced font (like Consolas) for code files (like .java) and a regular font (like Georgia) for txt files? I have always had

Global Style -> Global override

in Style Configurator and enabled Global font and Global size. That way everything had the same Consolas font. But text doesn't look as good in Consolas.

2

You can configure fonts, etc. individually with Settings > Style Configurator

enter image description here

| improve this answer | |
  • 1
    Thanks but how do you add txt files to that left list you have C# selected in? – strider Mar 22 '12 at 23:24
  • It knows about "Normal Text" usually, you only overwrite styles for C# etc – ADNow Mar 23 '12 at 0:47
  • 1
    Aha, went into Global Styles and chose Default Style for my txt font. And then like you said, set font for C# separately and it worked. What sucks is there are multiple entries that you have to set. Seems like you can't just set Consolas 9 at one place for C#. But this is OK too. Thanks. – strider Mar 23 '12 at 12:58
  • Glad it helped. – ADNow Mar 23 '12 at 21:47
  • 1
    @ADNow: This is still a problem because Default Style applies to Normal Text, which means that every language then has to be set to the programming font... (over a dozen occurrences), and then later, if the programming font is changed, that's over a dozen occurrences to change as well. Have you been able to work around that? – Assad Ebrahim Oct 1 '14 at 7:18
0

Sorry for my English.

In notepad++ v7.5.8 you can add "Normal text" as custom language:

menu "Language/Define your language...",

  • press "Create New...",

  • enter "Normal text",

  • in field "Ext." enter "txt",

  • in group "Default style" press "Styler", select your font and font size for normal text (use pop-up list to select size, entering by keys didn't work for me), then select foreground and background color, if you want to use default colors just right-click both color pickers (they will become lined),

  • in tab "Comment & Number" in group "Number style" press "Styler" and set font style for numbers.

That's it!

If you decide to change style settings for normal text go to menu "Language/Define your language..." again, choose "Normal text" from the list "User language" and change what you want. Be aware of another glitch: if you reopen Styler dialog it can "forget" if you right-clicked color picker and it won't be lined.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.