16

I have to start a QT-Program on the screen on startup in Linux Mint 9.  The monitor that is displaying the program turns off after an unknown amount of time.  I already deactivated the turnoff in the systemconfiguration, but it doesn't seem to work.

Hardware specs:

  • CPU: Intel ATOM 330
  • GPU: Nvidia ION (330)
  • 2 GB RAM
  • OS: Linux Mint 9

I can't change the OS and the other specs.  What can I do to solve this problem?

6 Answers 6

23

try:

xset -dpms
xset s noblank
xset s off 
2
  • i'll try your line as soon as I'm at work on monday, I'll reply back, thanks in advance :)
    – Linuxnewb
    Commented Mar 23, 2012 at 16:27
  • 1
    @Linuxnewb What was the result? Commented Oct 29, 2023 at 1:41
10

Issuing those three commands separately is unnecessary, according to Display Power Management Signaling at ArchWiki.  All you need is

xset s off -dpms

and all you want will happen.

1

Maybe this can help you.

In short:

xset -dpms
3
  • your link has rotten Commented Dec 22, 2023 at 15:12
  • @scrat.squirrel you could've proposed a change instead of downvoting. This answer is like 12 years ago, and sorry if I don't get notified whenever one of my links get rotten...
    – cYrus
    Commented Dec 23, 2023 at 12:40
  • sure, the answer in 2023 is: xdg-screensaver command. Commented Dec 24, 2023 at 13:30
1

Open the Power Manager. Select the Display tab. On the left where is says "Blank after", move the slider all the way to the left under Plugged In, or the corresponding power type, batter or plugged in. This is assuming it's not the screen saver that is making your monitor go blank.

This is for Linux Mint 17.2, so I'm not sure if it will be the exact same with your older version.

1
  • xset -dpms returns server has no extension for -dpms option for me but this works and is way simpler, thanks!
    – Alex
    Commented May 25, 2020 at 12:25
0

in my setup i could do this within my window manager xfce4 'xfce4-power-manager-settings'

0
-2

The winning combination:

xset s noblank dpms force on

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .