I am trying to install jEdit on my Windows 7 PC using the Java-based installer. However, I am getting this error that claims that I lack permissions to install jEdit within C:\Program Files (x86)\jEdit 4.5.0. I have verified that the folder does exist by pasting it into an address bar and going to it.

enter image description here

How come I can't install jEdit? I think I am the only user on my Windows 7 PC.

  • Maybe it's failing because the directory already exists? – Andrew Lambert Mar 23 '12 at 17:58
  • Thank you, but I tried installing both with and without the directory jEdit 4.5.0 made beforehand. Both times produced the above error. – David Faux Mar 23 '12 at 17:59
  • 3
    Have you tried the non-Java Windows installer package? – Andrew Lambert Mar 23 '12 at 18:05
  • Thank you, using the non-Java Windows installer worked. I wonder why. – David Faux Mar 23 '12 at 18:07

Try doing a run as administrator (or copy the file in using an administrator run Windows explorer).

  • I think I am logged in as an administrator though. I navigated to "User Accounts -> Manage Accounts" and saw that the label "Administrator" appeared below the user name of the user I logged in with. The only other user is "Guest." – David Faux Mar 23 '12 at 18:03
  • 2
    @DavidFaux Starting in Windows Vista the adminstrator runs as reduced privlages, that is what the UAC dialog is for, elevating privileges. If you never got the UAC dialog then you need to manually elevate the process by doing Run as Administrator. – Scott Chamberlain Mar 26 '12 at 15:03

In Windows 7, to write in Program Files and Program Files (x86) you need to be administrator. Using the java installer java cannot ask to become administrator and complete the install. You have to run the installer as an administrator or install jEdit somewhere else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.