38

I connected to a server via SSH in Terminal (OSX), but now anytime I open Terminal, it logs me back in. If I logout, I cannot type anything or do anything.

How do I exit back to the regular terminal so I can run a script on my mac? I realize this is probably a really noob question.

53

You can press Ctrl+D that will exit the terminal.

  • I get this message and then cannot type anymore: [Process completed] – miles Mar 23 '12 at 19:54
  • That is because you are in the local shell for your mac and exiting the process would be my guess. Typically you need to provide credentials to log into another server unless you have ssh keys setup. Are you sure that you are connected to the other server? – J Baron Mar 23 '12 at 20:35
  • this will exit whole terminal with ssh, @coffeeRain's answer is the correct one - use exit – OZZIE Feb 10 '14 at 16:12
  • 6
    You can also just type logout – JuJoDi Feb 13 '14 at 0:37
  • It should be either exit or logout to reply to the actual question. Closing the terminal ends the session, but it is not the "clean" way to do it – Marius Oct 3 '16 at 12:19
25

Try using the exit command in the Terminal.

  • I get this message and then cannot type anymore: [Process completed] – miles Mar 23 '12 at 19:54
  • 8
    If you are inside the SSH session and you type exit, it will leave the SSH session. If you are not inside an SSH session, it will close the terminal process, and then you will have to Command+Q to Quit the Terminal. – paradd0x Apr 1 '12 at 13:29
10

When exit doesn't work, I often have to use Enter~. (that is ENTER TILDE PERIOD) to log out of the emote server without killing the terminal window. This dumps me back into my local machine prompt.

  • What I like about this answer is that it is applicable to other *nix OSs. – John Giotta May 14 '15 at 0:19
2

If you’re using Mac OS X 10.7 Lion or later, Terminal automatically restores windows and terminal sessions that were open when you Quit (see “Resume” on the What’s New page for Lion). If you created the SSH session with the Shell > New Remote Connection… command, Terminal will remember and create that connection again when restoring that terminal.

If this is what you’re encountering, just close that terminal window/tab and create a new one.

If new terminals also exhibit this behavior, you likely have a custom command in your preferences. Look at Preferences > Settings > [profile] > Shell > Startup > Run command and see if there’s a command in the text field. If so, remove it.

Also check Preferences > Startup > Shells open with: to see if there’s a custom command being used for the shell.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.