7

When exporting a PDF from PowerPoint (I use PowerPoint 2010), each image that was inserted into the PowerPoint document from a file will have a tooltip showing the file name in the PDF. I didn't even know before that PDF elements can have tooltips. It is very annoying an distracting when the tooltips come up during a talk.

Question: How can I prevent the tooltips from being included in the PDF?

Note: Using alternate PDF viewers or alternate settings in Adobe Reader is not an option.

  • 2
    More than annoying. The file name and path name (where the images originally came from) included some unintended confidential information in a presentation I used in a screen-sharing session. >:( – Jason S Feb 26 '14 at 19:43
6

I found a workaround here.

To summarize:

  • The tooltips are included for accessibility.

  • To turn them off, change the options in the Save as PDF... dialog and disable "Document structure tags for accessibility"

enter image description here

2

That tooptip is generated from the Alt Text in Word. By default, it is the image file name/path you copied and pasted. It can be modified in Word or PowerPoint, as described here.

Alt Text in Word

To remove it, you have 3 solutions:

  1. In Word or PowerPoint, use File -> Print. This will remove all Alt Text.

  2. In Word or PowerPoint's Acrobat ribbon, choose Preferences, then uncheck “Enable accessibility…" Sorry for not having an English version. enter image description here

  3. Using acrobat.In Acrobat 9, go to Advanced > PDF Optimizer. (The path may be slightly different in Acrobat 8.) Under Discard Objects, make sure that Discard Document Tags is checked. This will remove alt text from images. You can also run this in batch (on multiple PDFs at once) by going to Advanced > Document Processing > Batch Processing. Decribed here.

1

Rightclick a picture, choose Format Picture. Click Alt Text and delete any text in the Description text box. That's where your tooltip text is coming from.

PowerPoint doesn't put text there (hence no tooltips) if you Insert the image from file. It DOES put the name of the image there if you use the Photo Album feature.

If you've got a lot of photos do do this with and don't mind whacking any other alt text in the presentation, you can run a bit of VBA to do the job for you:

Sub BlankTheAltText()
  Dim oSl as Slide
  Dim oSh as Shape
  For each oSl in ActivePresentation.Slides
    For each oSh in oSl.Shapes
      oSh.AlternativeText = ""
    Next
  Next
End Sub

Now when you save as PDF, no more tooltips

  • Thanks for the answer. I think I included the images using drag and drop, but I don't remember exactly. I found another solution, which I summarized in another answer. – Szabolcs Mar 26 '12 at 14:53
  • I like your solution better. It doesn't rely on throwing away information that you might want to use for other purposes. Thanks for posting that. – Steve Rindsberg Mar 30 '12 at 15:12
0

The solution is valid for Office 2010 and above

To manually remove the text>>

Right Click on image >> Select for "Format Picture" >> select for the option "Alt Text" located at bottom >> Clear the content from "Title" & "Description" >> Close the window. This will take care of the problem. For large number of images use the solution provided by Steve Rindsberg, just a small precaution here, see to it that provided images are not grouped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.