12

It appears that installing Windows 8 on top of XP doesn't give you the option to choose the locale and other settings -- I've got the right keyboard layout restored, and can change the system locale to be for the UK, but the system doesn't let me now change the time zone -- choosing the option to try to do it in the control panel, gives me the following error:


Date and Time


Unable to continue


You do not have permission to perform this task. Please contact your computer administrator for help.

[OK]

1
  • this was happening to me even in Windows Server 2012 so if you don't mind I will tweak the question to remove all references to Windows8
    – knocte
    Jun 7, 2016 at 3:33

7 Answers 7

16

The following did not work for me: * Add Users group to Administrative Tools > Local Security Policy > Security Settings > Local Policies > User Rights Assignment > Change the time zone.

After the reboot, i still could not change the timezone. I solved it by using Powershell instead. This is how i solved it on a Windows 2012 R2 server:

  1. Downloaded Powershell version 5.1 and installed it on the server.
  2. Rebooted server.
  3. Open Powershell with "Run as an administrator"
  4. Run command:

Set-TimeZone "W. Europe Standard Time"

2
  • 11
    The Get-TimeZone -ListAvailable command will help you to find your desired time zone. Mar 11, 2020 at 17:15
  • On recent Windows Server, this seems to be the way it is done now, noting that the 'Desktop Experience' is really just a layer above Core now. Apr 1, 2022 at 4:04
11

Looks like for whatever reason my installation didn't grant anyone, nor any group the privilege to change the time zone. I had to:

  1. Go to the desktop
  2. Open the charms bar (Win+c, float mouse to bottom right or swipe from the right)
  3. Choose Control Panel
  4. Switch to icon view
  5. Go to Administrative Tools folder
  6. Run Local Security Policy
  7. Expand the Local Policies section and click on User Rights Assignment
  8. Double click on Change the time zone permission
  9. Add local Administrators group.
  10. Reboot
  11. Change timezone in the normal fashion

(In later versions of Windows, you can simply open the Start menu and type Local Security Policy to skip to Step 6.)

4
  • 5
    in WindowsServer2012, there would be a missing step between 6 and 7, which is: Local Policies -> User Rights Assignment -> [step7]
    – knocte
    Jun 7, 2016 at 3:26
  • 4
    Administrators local group is already there and I'm a member of it but I'm still having this problem so this solution doesn't work for me.
    – JohnC
    Aug 22, 2018 at 1:37
  • 2
    Instead of adding local administrators group, I just added everyone and it worked for me. Also reboot seems to be necessary.
    – Feng Jiang
    Apr 28, 2020 at 14:38
  • On Windows server, this doesn't work and you need to use powershell (see answer by @Andreas) Apr 1, 2022 at 4:04
3

It makes no sense to me but the following config fixed the problem on my Win10 laptop which was upgraded from Win7 or Win8 (forget which). My login account was already in local Administrators group which was already granted the same config:

  • Add Users group to Administrative Tools > Local Security Policy > Security Settings > Local Policies > User Rights Assignment > Change the time zone.

Refer to Date and Time – Unable to Continue on Problem Solved answer site for detailed step by step instructions.

2
  • 2
    Reason you need to add the Users group into Administrative Tools > Local Security Policy > Security Settings > Local Policies > User Rights Assignment > Change the time zone is because the time/date applet runs in non-admin context So, even though you have a local admin account on the computer, the time/date applet isn't running in an administrative context... so belonging to the local Administrators group doesn't matter. The local security policy is applied at logon - you'll need to log off and back on before you can change the time zone
    – Greg Smid
    Jun 20, 2019 at 21:07
  • 1
    The reason you need to add the Users group into Administrative Tools > Local Security Policy > Security Settings > Local Policies > User Rights Assignment > Change the time zone is because the time/date applet runs in non-admin context (i.e. UAC doesn't present a prompt to see if you want to run it as administrator). Even though you have a local admin account on the computer, the time/date applet isn't running in an administrative context, so belonging to the local Administrators group doesn't matter. Don't forget that the local security policy is applied at login (so logout & login).
    – karel
    Jun 21, 2019 at 5:25
2

Just run command prompt with admin credentials and run this:

C:\Windows\System32>timedate.cpl

Set time as you wish.

Use the windows search to look for "timedate.cpl". next, right-click it and select "create shortcut". you will get a message about how windows can't create a shortcut there. It will ask you if you want to create a desktop shortcut instead. click yes (or accept or whatever). Right-click the desktop shortcut. Select 'Run as administrator (or whatever the exact option is. it's got the shield thing on it. just click that). Then you can change your time and date as you wish.

2
  • In my scenario, I was running as an administrator, and the issue was down to the Local Policy not being set as expected. Feb 3, 2020 at 9:33
  • This was the solution for a Windows 10 Home problem.
    – jaybrau
    Feb 20, 2021 at 17:56
1

To change the time zone currently being used please follow these steps:

1.From the Start page click on “Settings” and then click on “More PC Settings”:

2.Next go to “General” and select the new time zone from the drop-down list.

2
  • 2
    Well, the setting appears to be there, but it doesn't seem to stick, and my machine keeps defaulting back to Pacific Time (and as such didn't take into account the DST change last night) Mar 25, 2012 at 12:00
  • @RowlandShaw No idea abt that.
    – HackToHell
    Mar 25, 2012 at 12:36
0

Several people seem to have a problem with Windows 8 Consumer Preview and the time settings - including me. (It helps to know you are not alone!)

I fixed mine, but I wasn't paying full attention to the exact steps. I just remember going back to my Control Panel, Date and Time AGAIN, and the second or third time it took, set, worked, and hasn't given me anymore trouble.

0
0
  1. Create new Account and set it to Administrator 2.Goto control panel > administrative tools > Local security policy > local policies > User rights assignment > Change time zone

Then click add users or group, click advance find now and look for the account you created. after that login your created account/ user then change timezone. the go back to your current user.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .