I have a MacBook Pro running Windows 7 RC, which is connected to a Logitech DiNovo keyboard via Bluetooth.

If I don't use my keyboard for ~15 seconds, it takes 3-4 seconds before it responds to keyboard events again.

This started about 14 days ago... before that the same keyboard/computer worked fine.

If I pair the same keyboard with another computer running Windows 7 RC, I don't have any problems. If I pair another Bluetooth keyboard (Logitech DiNovo Edge) with the MacBook it also has problems.

I'm clueless about how to resolve this issue (except reinstalling Windows).

Does anyone have suggestions about how to problem solve this issue?

  • How are you running Windows 7? Under Boot Camp? As a virtual machine in Parallels/VMware? Sep 14 '09 at 14:39
  • Yes... Boot Camp. Works great. 64Bit by the way. Sep 16 '09 at 15:51

OK... I found the solution here. Thanks to groblus for saying the magic Google term: "Power management".

I've copied the solution from the link above:

Go to Bluetooth Devices (click the Bluetooth notification icon in the dock... err... taskbar) -> Open Settings.

Now click the Hardware tab, select Apple Built-in Bluetooth, and click Properties in the bottom right. A new window should pop up.

Click "Change settings" in the lower left (shield icon).

The window closes and a slightly different one opens. Go to the Power Management Tab and uncheck "Allow the computer to turn off this device to save power."


have you check all the options conserning power mamagement? I'm not windows 7 user but it looks to me like some sort of "power saving" enhancement. there was a simillar issue couple years ago with usb connected adsl modems - turing off every possible feature consenring energy preservation soveld the issue.
does it happen while on battery or all the time ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.