My Dad has a 2TB Seagate USB external hard drive (formatted NTFS) that is about 3 or 4 months old and has begun acting very strangely. If the hard drive is plugged in when you are starting or shutting down the computer, the computer will hang. We've tried leaving it for upwards of 4 hours, with no progress, but if you unplug the hard drive, it will finish immediately. This occurs on three different computers (2 XP and 1 windows 7). I've seen some indications that this may be related to "legacy USB support" in BIOS, but I have been unable to find that option on any of the available computers.

If you plug the hard drive in after windows has started up, then windows will recognize that the hard drive has been plugged in and the drive will show up on my computer, but it will not actually allow access. It will not show free space, attempting to open the drive will hang the computer, and going to the drive properties will instead route to the control panel system page. This precludes the usual method for running chkdsk.

I've tried to run chkdsk from the command prompt, both immediately and scheduling for a check on reboot, and neither actually runs anything. The command prompt just sits there, doing nothing.

Ordinarily at this point I'd call the drive a lost cause, except for the fact that if I plug it into my desktop, which runs Ubuntu 10.04, it works perfectly fine. My next step was of course to back up all of the critical data on it to another hard drive. Unfortunately, I have not been able to find much in the way of linux programs for checking ntfs drives. I ran ntfsfix, but that didn't produce any results (and may just have marked the drive to run chkdsk, which as noted, doesn't run)

Does anyone have any ideas as to what may be causing this issue?
Most of the data has been backed up, but it would still be a pain to format/replace the hard drive. Thanks for any help you can provide.

UPDATE: For reference, I did end up returning the drive. Soon after, we had a number of usb sticks fail after using them in a specific USB slot. Booting that computer up in Ubuntu gave an error message indicating that the USB slot wasn't providing the right voltage. So, it looks like a dying USB slot is what did the damage to the hard drive. No idea why it still worked on my desktop though.


I wouldn't try fixing the drive at all. Get as much as you can off it, and return it for a replacement. It's still under warranty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.