Today, I tried to install packages through apt-get, but I encountered a lot of 404 errors. My sources.list was fully working last Friday (no changes to my knowledge), now I get:

W: Failed to fetch http://ftp.fi.debian.org/debian/dists/lenny/main/binary-amd64/Packages  404 Not Found [IP: 80]

W: Failed to fetch http://ftp.fi.debian.org/debian/dists/lenny/main/source/Sources  404 Not Found [IP: 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/binary-amd64/Packages  404 Not Found [IP: 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/source/Sources  404 Not Found [IP: 80]

When I browse for example http://security.debian.org/dists/ there seems to be no lenny directory. What's the issue?

  • Ok, it seems that lenny is moved to archieve. No suprise as it's passed already EOF: wiki.debian.org/DebianLenny
    – Fdr
    Mar 26, 2012 at 7:42
  • Noticed the same just lately a and decided to move on. Will take me a night or so, but still better this way. The machine should have been better maintained in the first place :) May 10, 2012 at 13:35

4 Answers 4



  • Lenny is EOLed
  • lenny security updates have been terminated on February 6th
  • lenny backports have been dicontinued on March 25th
  • lenny volatile has been discontinued with the release of its successor "squeeze"

the repositories have been moved to archive.debian.org - you may wish to update your repositories to match this:

deb http://archive.debian.org/debian/ lenny main non-free contrib
deb-src http://archive.debian.org/debian/ lenny main non-free contrib
# Volatile:
deb http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
# Backports:
deb http://archive.debian.org/debian-backports lenny-backports main contrib non-free
# Previously announced security updates:
deb http://archive.debian.org/debian-security lenny/updates main
  • You saved my life and sanity with that answer. Thanks a lot! Jan 6, 2013 at 11:42
  • i've got W: GPG error: http://archive.debian.org lenny/volatile Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DFD993306D849617
    – holms
    Feb 1, 2013 at 6:29

I think you want to

gpg  --keyserver subkeys.pgp.net  --recv-keys DFD993306D849617

to avoid the "NO_PUBKEY" error.


The other answers didn't work for me - this worked:

mv /etc/apt/sources.list /etc/apt/sources.list.PREARCHIVE

From http://forums.debian.net/viewtopic.php?f=10&t=95658, make new /etc/apt/sources.list with

# SOURCE: http://superuser.com/questions/404806/did-debian-lenny-repositories-vanish
deb http://archive.debian.org/debian/ lenny main non-free contrib
deb http://archive.debian.org/debian-backports lenny-backports main
deb http://archive.debian.org/debian-backports lenny-backports-sloppy main


gpg  --keyserver subkeys.pgp.net  --recv-keys DFD993306D849617
apt-get update 
  • gpg needs some funny port number to request keys. How annoying. Why don't the use port 80.
    – Kaz
    Oct 28, 2013 at 19:57

For people who like me are searching for a place to download individual packages for the Debian 5 Lenny the best option as of now is archive.debian.net

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.