I am getting <20KB/s for local network file transfer.

If I transfer a very small file (less than 100KB) it would start quickly then slow down to <20KB/s. all subsequently network file transfer would be slow, a reboot is needed to reset this. If I transfer a large file it would be stuck on calculating for a long time and then begin with <20KB/s immediately.

This is a newly built desktop running Windows 7 x64 SP1. Realtek gigabit LAN from the motherboard (ASRock Extreme3 gen3). Problematic speed is observed on the private LAN, both through ethernet and WiFi. The Router is D-Link DIR-655. Remote Differential Compression is off. Drivers are up-to-date from ASRock's website.

I have tested network file transfer to and from another Windows 7 laptop and a MacBook Pro, so I am fairly certain it is the desktop's problem. The slow speed only happens with one direction also, outbound from the desktop, regardless of whether I initiate the file transfer action from the origin or the destination. Inbound network file transfer and internet speeds are fine, so I don't think this is a hardware issue.

I am getting 74.8MB/s internet upload speed from speedtest.net (http://www.speedtest.net/result/1852752479.png). Inbound network file transfer I can get around 10-15MB/s.

I am hoping this community has some insight for me to troubleshoot this. I don't see anything obviously related from the Event Viewer, and beyond that I just don't know where else to look.

Any suggestions are greatly appreciated, thank you in advance.

  • I've seen similar behaviour on a couple machines, and it pointed to the NIC driver, or card itself. It's strange that you're seeing the same issues on Wi-Fi and Ethernet, though. Perhaps the motherboard chipset drivers need a look? Have you tried a USB-dongle Ethernet connector? That solved the problem on my laptop.
    – user3463
    Mar 27, 2012 at 6:13
  • Turns out it was a driver issue. The ASRock driver was just not working for me, however after I searched for and installed the NIC's reference driver directly from Realtek, everything started working again. I now have about 15MB/s both up and down. It is not gigabit LAN like it is supposed to be, but at least usable in the normal sense for home networking.
    – Mangoshake
    Jun 24, 2012 at 10:52

6 Answers 6


I'm not sure if you're still having this problem but I found this post after having the exact same issue.

I have the same motherboard as you and I'm using a 64-bit installation of Windows 7 connected to my home network using gigabit Ethernet.

I managed to find a solution after reading another super user question and some experimentation:

I went to the configuration screen of my network adapter and changed the following configuration settings:

  • Large Send Offload V2 (IPv4) = Disabled (was Enabled)
  • Large Send Offload V2 (IPv6) = Disabled (was Enabled)

I guess this is a driver issue. I haven't scouted out for an updated driver so I'm not sure if there is a newer version (and whether this issue is fixed).

This has solved this frustrating problem for me. I hope it helps you.


Check link speed and duplex under the network adapter settings. Change to auto negotiation if anything else is selected. This took me 6+ hours of troubleshooting. This site finally had me looking in the right place.


The following settings worked for me after a couple of configurations and tests. I tested both small files and big files. I also tested extracting a zip file (SysinternalSuite.zip) directly on the File Server. It definitely seems to be a driver issue. Last but not least, I unplugged my network cable from my Thunderbolt 27" Display, which also made a huge difference in performance. Seems like my Apple setup doesn't like the Windows Kernel...

MacBook Pro 17" Mid-2011 (i7 2.2, 16 GB, 750 GB, ATI)

Broadcom NetXtreme Gigabit Ethernet

  • Ethernet@WireSpeed = Disable
  • Large Send Offload (IPv4) = Disable
  • Large Send Offload v2 (IPv4) = Disable
  • Large Send Offload v2 (IPv6) = Disable

Network Speed


I have a solution for speed problem

  1. Start menu
  2. cmd then Enter
  3. type netsh int tcp set global timestamps=enabled then press Enter

Open the Network and Sharing Center. Click on Change Adapter Settings. Right click on whichever connection you are using and click Properties. Uncheck the box for AppEx Networks Accelerator. It is not even present in Windows 7/8 32 bit...

It solved my problem.


Unchecking AppEx worked for me using Windows 10 Home Premium. File transfer in Filezilla accelerated to over 10X faster speed before it ran out of file to transfer. Was at around 10kbps.

  • The question specifically asks about Windows 7. Does your suggestion work for Windows 7? Aug 20, 2015 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.