I'll try to explain my situation:

I am a developer and use Visual Studio. I always want to run Visual Studio as administator. I have pinned a shortcut to the task bar and in its properties set it to start Visual Studio as administrator. This works fine.

When I right click on the pinned shortcut, I see a list of recent and pinned solutions. I usually open Visual Studio by clicking one of those pinned solutions.

When I click one of those recent or pinned solutions, I do not get a UAC prompt. I remember that before I would always get this (at least, I think I remember).

Is there anything I can do to make Visual Studio run as administrator when I click on those recent or pinned solutions?

The trick is to change the compatibility settings (i.e. always run as administrator) for the executable (devenv.exe), not the shortcut. After you make the change you may need to re-associate the .sln extension with devenv.exe

There's a blog post at mo.notono.us explaining how this is done.

Edit: If the compatibility tab is missing on the devenv.exe then use the compatibility troubleshooter to enable it - No compatibility tab for Devenv.exe (VS 2010 and VS 2012) on Windows 8

  • 2
    Thanks for your answer, this seems to be the answer I'm looking for, but I can't get it to work. I don't have the compatibility tab, but the compatibility troubleshooter solution also doesn't work. It says "Settings applied: User Account Control: Run as administrator". I click "Start the program" and it just starts. I click next and tell it to save the settings. But I still don't get the UAC prompt when I start Visual Studio through the jump list. – Matthijs Wessels Aug 30 '12 at 8:16

I found this page by looking for something as trivial as to set up a task bar shortcut to always run the command prompt as administrator.

Richard's answer will work with programs that are not considered to be part of Windows' install (i.e. Visual Studio here), but probably not for stuff in C:\Windows\System32 for instance.

Luckily you can set Run as administrator option from the shortcut in this case.

  1. Right-click the shortcut in your task bar
  2. Right-click the program's name (say Command prompt for instance)
  3. Click on Properties
  4. Click the Shortcut tab
  5. Click the Advanced... button
  6. Check the Run as administrator check box
  7. Click the OK button
  8. Click the previous OK button
  • This is a much better answer than the one above, IMHO. – Andy Brown Apr 27 '16 at 12:57
  • This is solves the problem way better than the accepted answer. – sanepete Sep 24 '16 at 17:59
  • This should be the more accepted approach. Cleaner, easier, and works perfectly. – Corey Witherow Oct 7 '16 at 12:30
  • This option does not work if you try to use a jump list item. If you launch it directly it does launch as administrator, try and launch using the recent items and it launches as normal. The first option does work. – tsells Jan 30 '17 at 19:02
  • This does not answer the question. If you click on one of the "pinned" solutions in the pop-up list, it will not be opened in VS "as administrator". – Svein Terje Gaup Jun 1 '17 at 4:50

Search for "Visual Studio" to locate your devenv.exe

Or, if you know where it is:

  • Right click on it
  • Click on properties
  • Click on the "Compatibility" tab

You should see a checkbox that says "Run this program as an adminstrator" under privilege level setting

  • check the checkbox
  • un-pin visual studio from the taskbar.
  • drag the denenv icon to the taskbar to pin it on it

Now if you click on the shortcut on the taskbar, it should run as administrator

  • I don't think he has to re-pin it. The compatibility setting is stored globally for devenv.exe in the registry. – Ray Koopa Apr 22 '14 at 8:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.