2

I cannot seem to empty the Trash in OS X. I can open the Trash folder and view the items, but somehow cannot empty (or even secure empty) trash. Is there any way out?

The following dialog seems to run forever. I tried restarting, but it doesn't help.

Image of the "Emptying the Trash…" window with an empty progress bar and 70 items to delete.

3

Try using Disk Utility to do a "Repair Disk" to eliminate volume data structure corruption as a possible source of the problem.

2

See if there's an app using a file in .Trash using lsof

$ lsof | grep Trash

Close open files and/or quit the apps holding open files in .Trash.

2

Try Terminal command rm -Rf ~/.Trash/*

  • If this doesn't work, run it with sudo. – user3463 Mar 28 '12 at 17:47
0

This Trash It app has worked every time for me. It's really quite brilliant and super simple to use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.