5

As one example out of many, if you go to https://appleid.apple.com and click to manage your account, you can't paste your password in the password field. There is some javascript that prevents that. Is there a convenient way to disable that? It breaks normal browser behavior to not be able to paste, and additionally, it discourages the use of strong passwords (I use a password manager and copy & paste from it to the site).

Thanks!

3
  • 1
    I am able to paste my password without any problems. The simple way to prevent something like this is to disable said javascript. I had no problem copying and pasting a password from LastPass.
    – Ramhound
    Mar 28, 2012 at 18:19
  • Websites forcing javascript makes me a sad panda :( "To manage your Apple ID, your browser must support Javascript. If you're using Safari, confirm that Javascript is enable in the Security pane of Safari Preferences. " with noscript installed. Enabled scripts, can't paste password.
    – Rob
    Mar 28, 2012 at 18:26
  • Note that Ctrl-V pastes into some fields even when the paste menu option is disabled.
    – Dan D.
    Mar 28, 2012 at 20:38

4 Answers 4

5

I created a JavaScript bookmarklet that removes all onpaste events from password fields. I haven't extensively tested it just yet, but I know it works on appleid.apple.com as that's the reason I wrote it.

See http://prioritized.net/blog/re-enabling-password-pasting-on-annoying-web-forms/

3
  • As a bookmarklet, it requires choosing that bookmarklet when on an offending site, right? Is it possible for this to be a browser extension that works everywhere? I saw your note on your post that you set this up for Mobile Safari as well. My guess is that a browser extension would work for Chrome on iOS as well. -Just some thoughts / the reason this doesn't solve it for me totally.
    – ezrock
    Aug 9, 2012 at 18:15
  • Yes, it could. I've never written an extension and use multiple browsers so I didn't really have an interest in doing so. Aug 21, 2012 at 17:55
  • 1
    You're link is dead, please share the code here.
    – noraj
    Dec 1, 2019 at 23:27
4

bypass a website’s copy-paste restriction on Firefox:

type about:config in the URL. Find

dom.event.clipboardevents.enabled

and set it to "false". (Firefox won't allow anymore the websites to mess with your clipboard).

All the glory to digitwonk

0

There is a Firefox add-on that certainly works for your example:

https://addons.mozilla.org/en-US/firefox/addon/righttoclick/

Not a perfect solution because you have to click the "right to click" icon first and then click and paste in the password box. But not bad.

1
  • This was a malicious addon and it was removed.
    – noraj
    Dec 1, 2019 at 23:36
0

The most bullet-proof way I can think of is to just temporarily disable JavaScript, then paste the password(s), then re-enable.

I had to do this with ebay just now, because even removing the onpaste attributes didn't help (and I didn't feel like spending any more time trying to uncover/bypass whatever other blocks they had in place).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.