Some times I have issues with the wireless connection where I live. That issue is irrelevant to this (there are two IT departments managing this thing; there's nothing I can do about it). Most of the time it's nice and fast, but sometimes slows to a crawl (single digit KB/s sorts of crawl).

Anyway, I think Firefox (11.0 Ubuntu) might not be using its cache correctly. When (for testing purposes) I set it to "Work Offline", pages load on the order of a second. Normally, the same page (benchmarked on http://kb.mozillazine.org/About:config_entries ) loads in around three seconds when the connection is working properly, and ten or more when it's not. I can confirm it's reloading things, since I see a spike on my bandwidth-use graph while when I open the page. I think image caching is still working properly, since it doesn't seem to be very much bandwidth used though.

Shouldn't Firefox just be using the cached copy of the page (checked; exists in the disk cache) instead of downloading a new copy, when I open the page in a new tab?

I know that some content is set to expire, so it should download a new copy. I don't believe that the example page has one of those. Under "Work Offline", pages like gmail did not load, so I assume that that is the proper behavior of pages that expire.

How can I either make firefox use cache unless the page has expired, or, better yet, display the cached page while it tries to load a new copy?


You can try to install the Web Developer Toolbar and disable cache on it.

  • But @zebediah49 wants to do the opposite. ;-) – Nicolas Barbulesco Apr 16 '14 at 12:53
  • 1
    That is right. My mistake :) – awavi Apr 25 '14 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.