I have currently have Ruby 1.9.1 (bad) and want to install 1.9.3 under rvm. However, rvm requirements gives a long list, most of which installed fine:

install build-essential openssl libreadline6 [...] bison subversion

But I hit a problem here:

/# apt-get install libreadline6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package libreadline6

I need libreadline6 before I can get rvm to install Ruby 1.9.3, what's a good way forward?

My sources.list:

deb http://ftp.cn.debian.org/debian-volatile lenny/volatile main
deb-src http://ftp.cn.debian.org/debian-volatile lenny/volatile main
deb http://archive.debian.org/debian/ lenny main contrib
deb http://archive.debian.org/debian-security/ lenny/updates main contrib

Update: Finding usable urls for sources (updated above), installed all but libreadline6 and libreadlin6-dev, neither of which are available for Lenny. Will post solution here when I find one.

  • 1
    The error that you're having does have to do with your sources moreso than what you're trying to install. Personally, I've never used nor had to use RVM. – kobaltz Mar 30 '12 at 18:54
  • I thought about not bothering with rvm, but found it useful locally so wanted to replicate on server. What sources would you recommend for Lenny? libreadline6 is the first package in the above list which isn't installed and can't be found... BTW this is for Camping, I'll never use RoR. – Dave Everitt Mar 30 '12 at 23:06
  • I've updated my sources (debian.org/News/2011/20110525) but still no joy: Couldn't find package libreadline6 – Dave Everitt Apr 1 '12 at 15:01

Whenever I create a new node for my rails application, I have a general installation script that goes through and installs the necessary dependencies and packages that I need. I first login as root and will then run the following. It is working on Ubuntu 11.04, Ubutu 11.10 and Ubuntu 12.04. This may help you solve your issue. This command will install Apache, PHP5, Ruby, Rails, and Passenger.

sudo su

apt-get update && apt-get upgrade -y && apt-get install libopenssl-ruby build-essential nano libmagic-dev coffeescript zlib1g-dev libyaml-dev libssl-dev libmysqlclient16-dev ntp ntpdate apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp libcurl4-openssl-dev apache2-prefork-dev libapr1-dev libaprutil1-dev samba smbfs libmagick9-dev git-core git-gui git-doc libreadline5-dev -y && a2enmod suexec rewrite ssl actions include && a2enmod dav_fs dav auth_digest && /etc/init.d/apache2 restart && wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p125.tar.gz && tar zxf ruby-1.9.3-p125.tar.gz && cd ruby-1.9.3-p125 && ./configure && make && make install && && gem update --system && gem install rails && gem install passenger && passenger-install-apache2-module

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.