I have a laptop that seems to have lost permission to create, update or delete files. It doesn't happen for every file, however.

Microsoft Office will not save any new files. Some other non-Microsoft programs can't save files either. For example, programs that have an auto-save feature throw errors about permission. Notepad seems to work. I can make new text files and edit them. However, when I try to delete the text file, I get the following error:

Cannot delete New Text Document: Access is denied.
Make sure the disk is not full or write-protected and that the file is not currently in use.

When saving a document in Word or another Office application, the file appears to save, but the Save As dialog pops up again. If I save it again, I get the error (see also https://i.sstatic.net/zXywS.png):

Word cannot complete the save due to a file permission error.

Two files are show on the desktop, however when I close Word, the files are removed.

I have also seen the following error when trying to delete a file. The file in question was a temporary text file, and it was deleted. The file didn't end up in the recycle bin, however.

The Recycle Bin on C:\ Is Corrupt or Invalid. Do You Want to Empty the Recycle Bin for this...

When a flash drive is plugged in, you still can't save files to the flash drive.

Word cannot complete the save due to a file permission error.

I CAN save to a shared folder on the network, however.

This machine is my parent's laptop, so I don't know the full history on when the errors started happening. We have tried to make sure all folders were not write protected. The errors are happening to both of my parent's log-ins, so we don't believe it is account-level permissions. Both accounts are admins. They seem to have XP SP3 and are generally up to date on updates.

Office seems to have a few more problems than just saving. On one account, Word tries to run some sort of installer and fails when starting up. It doesn't do this on the other account. The shortcuts for MS Office have the generic file icon. I tried to run a Repair on Office the other day and it just hung half way through. My Dad says he was able to complete it the next day and I haven't tried again.

Our problem actually sounds similar to this question, but in their case they are using Windows 7. File Permission Errors Also in our case, a re-save of files does not work.

Update 4/18/12: There have also been a few windows updates that have failed. The most prominent ones are .NET updates. I started focusing on this problem. I managed to uninstall all the .NET frameworks on the machine, and was only able to reinstall the 1.1 framework before I ran into file permission problems. I turned on MSI logging and eventually found this blog post. I didn't get very far in following those steps, however, because I could not install the SubInACL tool. I found another blog post which I thought may help with this, but after following the steps I was still unable to isntall SubInACL due to permission problems.

There seemes to be a deeper permission problem. I found something that suggested I make sure the SYSTEM and Everyone groups have Full Control permission on the folders. I found that somehow ALL of the permissions on Program Files had been removed, and the permissions on the C: drive were questionable. Using the Administrator account in Safe Mode, I gave ownership of Program Files and subdirectories to the Administrators group. Then, I duplicated the permissions layout of C: and Program Files from a working XP install.

This allowed me to install the first service pack for the .NET framework 1.1, but further versions and updates to .NET continue to fail. I was able to install and run SubInACL, but it didn't fix the updates either. I am still unable to delete files on the desktop. It also fixed an error that Skype was throwing on start-up, so at least there's a little progress.

Update 4/24/12: I managed to install the .NET 1.1 service pack with a manual install. I tried the .NET 3.5 downloadable bootstrapper and it told me that it couldn't download the files it needed. I also tried the full pre-downloaded installer, and it continues to error with the code 1603.

I ran chkdsk, and it did not find any problems. The SMART status for the drive is good. I don't believe there are any physical problems with the drive.

Update 4/29/12: I tried an XP Repair installation. The install hung near the end at the black screen with the Windows XP logo. Normally that logo has a "progress bar" and is full screen, but here it said "please wait..." and was smaller than full screen. I let it sit for several hours, but nothing changed. When I forced a reboot, Windows would boot and let me log in. It went through loading the desktop and loading settings, but it blue-screened with STOP c000021a, 0xc0000005. I believe the STOP error comes because the installation didn't finish properly. ... Turns out if I just let it sit on the log-in screen, it still hits a STOP error.

  • Can you take a screen shot of those two files which appear on desktop when you open the MS Word. And when you started to get this problem.
    – avirk
    Commented Apr 2, 2012 at 1:54
  • @avirk i.imgur.com/soKm3.png The two files are in the lower left corner. One is the first doc it tried to save. 0 bytes. The other is a Word temp file, ~10kb. Commented Apr 2, 2012 at 2:32
  • Is there any restore point you created on which your system working properly? If yes then try to restore it.
    – avirk
    Commented Apr 2, 2012 at 4:30
  • Why not just post that as an answer? Unfortunately, I just finished trying several restore points. I went back as far as I could (Jan 17), but it still has the same problem. Commented Apr 3, 2012 at 2:58

1 Answer 1


In the end, I decided that the problems were too deep for me to fix. When I looked up related installer or program problems, the fixes I found never worked completely. I started over with a clean install.

Since my parents kept the Windows XP and laptop driver/software cds, I was able to fully reinstall everything the laptop needed. I copied the home directories where they kept all their data to another drive. Luckily they didn't have data spread around the machine. Once everything was reinstalled and updated, it was easy enough to put their data back in place. So far so good. My parents are happy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .