0

I have followed this guide:

http://www.club.cc.cmu.edu/~mdille3/doc/mac_osx_serial_console.html

And I installed the closed-source Prolific driver (the open source one and the FTDI ones always gave out a AppleUSBCDC error and didn't work both, I suspect it's because this Mac Mini is 64bit?). So now I have both tty.usbserial and cu.usbserial on /dev.

I also tried the .plist file mentioning getty, and getty is running but I can't get the terminal to talk to it. Even echoing something to /dev/tty.usbserial does not make it show up on the terminal.

Maybe it's because the 19200 entry on /etc/gettytab has "g|" behing it? Excerpt:

2|std.9600|9600-baud:\
        :np:sp#9600:
g|std.19200|19200-baud:\
        :np:sp#19200:
std.38400|38400-baud:\
        :np:sp#38400:
std.57600|57600-baud:\
        :np:sp#57600:
std.115200|115200-baud:\
        :np:sp#115200:

Here is the .plist file I was using:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
        <key>Label</key>
        <string>serialconsole</string>
        <key>ProgramArguments</key>
        <array>
                <string>/usr/libexec/getty</string>
                <string>std.19200</string>
                <string>tty.usbserial</string>
        </array>
        <key>KeepAlive</key>
        <true/>
</dict>
</plist>

I also tried using 'cu.usbserial' - still no go. Also, I'm not sure if I need to set some setting on the VT100 to make it work, but I assume it's pretty much plug-n-play. Right? :) If the VT100 does not work at all with USB/serial converters, then I guess there's no point but I don't believe so. The terminal in question is this one:

http://www.columbia.edu/cu/computinghistory/vt100-2.jpg

Thanks for any help, really wanted to see the dinosaur kicking again!

4
  • 1
    I love those things. Spent hours typing in Pascal on them in college.
    – Alan B
    Apr 2 '12 at 14:13
  • Me too. I actually used a different kind of terminal to access a VAX back in the day, but they're really great pieces of hardware. Wish I could make this one work again Apr 3 '12 at 8:03
  • This was accessing a VAX 11/780, and DEC Pascal. These and VT52 terminals. I'd spend 30 minutes banging in code (and with the cast iron, sprung keyboards on those things you really got a workout) and then 15 minutes waiting for it to compile. Tell that to kids these days etc etc ...
    – Alan B
    Apr 3 '12 at 8:19
  • my Pascal days were spent on 386s and 486s with Turbo Pascal. That was fun :) Apr 3 '12 at 9:24
0

I got this to work with a Plugable adapter (Prolific PL2303HX chipset), but I had to use /dev/cu.usbserial instead of /dev/tty.usbserial.

It was helpful to use screen to test the connection -- it allowed me to figured out that my cable was wrong. I used the DB9-DB25 connection from here:

Text-Terminal-HOWTO / Physical Connection

Remember that you cannot run getty from the command line in recent versions of OSX -- it has to be started by launchd. You have to use a plist file as outlined here, and use launchctl to load and start it.

0

I had a lot of the same problems trying to get a VT220 to work with my Mac. The thing that eventually solved my problem was using a Tripp Lite Keyspan USB to Serial adapter. Here's a link to the Tripp Lite adapter and the drivers. http://www.tripplite.com/high-speed-usb-to-serial-adapter-keyspan~USA19HS/

Previously I had tried two different USB to Serial adapters, one that used the Prolific drivers, and they didn't work.

Make sure to check your cables too. I purchased a null modem cable that turned out to be wired incorrectly or damaged. You can do that with a multimeter. You might have to search for a different pin-out if you're using a DB9 -> DB25 or something like that.

Here's a breakdown of what I did and what worked if you're curious: https://gist.github.com/albertfilice/0f12dc87f8d1ec02ef14

-2

on your plist file, on the second stringparameter, just have the letter g. this matches the entry in your gettytab file. as i understand it, the first letter, followed by the bar, is the entry name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.