21

When I download a PDF or image in Google Chrome on my Mac, is it possible to prevent Chrome from automatically opening it in my default application for that file type (e.g., Preview)?

I notice that Chrome does not do this for other downloaded files such as audio and ZIP archives.

I still want to be able to preview files in Chrome; I just want to prevent it from automatically launching my image/PDF viewer application after I download them.

For example:

  1. I click on a link in an email to a PDF document or an image file.
  2. Chrome displays the contents in the browser.
  3. I press Cmd-S and save the file to my computer.
  4. When the download finishes, the file opens automatically in Preview.app.

It's that last step that I would like to bypass.

13

You can set the auto-open preferences for PDF files by clicking on the download status button in the downloads bar. When you have a downloaded PDF sitting there, click on the arrow and unselect "Always Open Files of This Type" in the pop-up menu.

You can also reset all the user preferences for auto-open by following the directions below from Chrome's help site at http://support.google.com/chrome/bin/answer.py?hl=en&answer=95759

If you want certain types of files to always open after they're done downloading, click the arrow next to the file button in the downloads bar and select Always open files of this type. To prevent potentially malicious files from automatically downloading to your computer, this option isn't available for executable filetypes, such as those with .exe, .dll, or .bat extensions (for Windows), and .dmg extensions (for Mac).

You can clear auto-opening settings through the Settings dialog. Here's how:

Click the wrench icon on the browser toolbar. Select Settings. Click the Under the Hood tab. In the "Downloads" section, click Clear auto-opening settings. This clears your settings for all file types. Click Close when you're done, if you're using Windows or Linux.

  • 5
    This no longer works. – user3241 Mar 12 '17 at 16:37
  • Changing the setting through the Download Bar does still work and is currently the easiest solution by far – Matt Jun 23 '17 at 14:58
  • In Chrome 67, it seems that for some downloads (at least PDFs), the download bar is never displayed. Opening the Downloads page does not have the reset opening preferences under any contextual menu that I can find. Opening this sample test PDF is one way to reproduce this - www.pdf995.com/samples/pdf.pdf. – Taylor Edmiston Jun 18 '18 at 21:46
6

Here is what I have done and it worked for me. Apparently this is not an OS issue, it is rather a browser issue.

If you are using Google Chrome, go to settings, then go to the very bottom of the page and click on "Show Advanced Settings" then under 'DOWNLOADS' uncheck the part that says you have opted to open some files by default.

If you are using Safari, open Safari preferences and on the general tab, uncheck "automatically open safe files" since Safari has this as a default option and unfortunately, pics that open are considered safe files.

  • This does not work on Windows 8.1 with V56. – user3241 Mar 12 '17 at 16:38
  • Works in Chrome on macOS. – frhd Apr 17 '17 at 12:11
3

On Mac, the above answers were not enough for me unfortunately to stop auto-opening of PDFs in Preview by Chrome.

The answer was to manually edit the preferences files for Chrome.

First, quit all running instances of Chrome.

Then, run this in your Terminal:

# Go to Chrome directory:
cd ~/Library/Application\ Support/Google/Chrome 

# List files that have any open_pdf settings:
grep -rl open_pdf .

Open each Preferences file listed in your text editor (this will be 1 or more Preferences files depending on the number of User Profiles you have set up in Chrome), and find all the always_open_pdf_externally and open_pdf_in_system_reader preferences. Change them so they are false:

"open_pdf_in_system_reader":false

"always_open_pdf_externally":false

Next, save changes and close the Preferences file(s).

Finally, open Chrome and see if this has helped. PDF downloads should not be auto-opened any longer.

  • THIS! Thank you so much! - Finally an annoying behavior of Chrome less. – CodeBrauer Jun 27 at 10:03
0

This is a known issue that was recently fixed. Eventually you will get an update that includes the fix.

https://bugs.chromium.org/p/chromium/issues/detail?id=680202

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy