I need to setup a XEN-Server in order to create a virtualized environment. I have successfully done this in a desktop pc but now when I installed the same in my Dell Inspiron laptop, the installation completed successfully.

However the BIOS says "OPERATING SYSTEM NOT FOUND" and I am not able to run XEN. What's more, I cannot even install any other OS into my laptop! Tried installing WinXP, Win7 and Ubuntu... No gain! I think that installing XEN has created some serious issues with my laptop's BIOS!

Can anyone please save my day?

migrated from stackoverflow.com Apr 4 '12 at 14:45

This question came from our site for professional and enthusiast programmers.

  • It could be a problem with the hard disk not being detected properly, a disk failure, or a bad MBR on sector 0. Have you tried booting off of a different hard drive? – paradd0x Apr 4 '12 at 14:57
  • No... How to do that? – gargie Apr 4 '12 at 15:00
  • Oops, you're on a laptop. It might be a bit more difficult than anticipated. Can you boot off of a USB? – paradd0x Apr 4 '12 at 15:14
  • Boot off after instailling or boot for installing??? XEN does not boot from usb FOR installing. – gargie Apr 4 '12 at 15:17
  • You mentioned that you have tried to install other OS's. Have you booted off of USB to install those? – paradd0x Apr 4 '12 at 15:21

You should set advanced options at install time.

When the Xen installer starts hit F2 and type the following:


Then use either the vim or nano text editors to modify a file.

nano /opt/xensource/installer/constants.py or vi /opt/xensource/installer/constants.py

Change the line that reads GPT_SUPORT=True to


Save the file, quit the editor and type


at the prompt. There is a clash between the BIOS and Xen when GPT is enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.