12

I can't find the option to enable line numbering. It'd be very helpful!

  • Nevermind, I hovered over the grayed-out option and it said to install gnome-python-desktop. – trusktr Apr 5 '12 at 7:14
3

Just believe it needs other dependencies, I saw them on Meld homepage but they are optional. On Fedora, try this

yum install gtksourceview
yum install gnome-python2-gtksourceview
yum install gnome-python2-gnomeprint 
| improve this answer | |
5

I had this problem on Ubuntu and just to spare another unobservant person the time I spent digging around for it I thought I'd add an answer here as well.

If you go into preferences you can see that the option to show line numbers is grayed out but if you hover over it it says to install python-gtksourceview2.

So on ubuntu:

sudo apt-get install python-gtksourceview2

And you should be good to go.

| improve this answer | |
3

The previous answer said to go into preferences within Meld. However, I can't see any preferences menu entry, which is consistent with the following post I found that proposed a solution with dconf-editor to toggle line numbers on/off.

Steps:

  1. Open dconf-editor
  2. Navigate to the path org.gnome.meld
  3. Toggle the setting for line numbers:

dconf-editor screenshot

For me, on Ubuntu 18.04, I didn't need to install any additional dependencies.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.