I have this office laptop running Windows 7 Enterprise 64bit, which will not detect the 'Domain network' profile after a full boot/reboot until I disable/enable the network adapter or that I disconnect/reconnect the network cable, while it's connected to the office's network.

The network shows as "Unidentified Network" with "No internet access". Once I reset the adapter or replug the cable, it's detected without trouble and shows as 'Domain network' with internet access as it should.

I've searched all over for a solution and so far I have not found anything helpful. I have tried enabling the "Always wait for the network at computer startup and logon" policy but it didn't change anything.

EDIT: The same issue occurs whether Windows Firewall is enabled or disabled, so it's not a firewall issue.

EDIT: I checked my NIC drivers and they are up to date (dated 12/02/10), so it's not a driver issue or at least, not likely. Windows can't find newer drivers online. (Using: Broadcom NetXtreme 57xx Gigabit Controller)

Note: Our company is using Sophos Safeguard 5.5 to encrypt the whole system, so I'm going through the Safeguard logon pass-thru before I get to Windows.

Any suggestions?

  • Have you tried upgrading you Network drivers to the latest offered by the manufacturer? After you 'fix it' by replugging, how long does it last, and what are the circumstances around it failing when it happens? – Ƭᴇcʜιᴇ007 Apr 5 '12 at 20:14
  • It's not an intermittent issue. It's only when I log in after a full shutdown or a reboot. Once I "fix" it it stays fixed until I reboot. My laptop is a Dell Latitude E5520 which comes with Windows 7 by default (branded with Windows 7 logo too). I have not tried updating drivers, but I had no reason to believe I needed to since it's not an intermittent or stability issue per say. – Yanick Girouard Apr 5 '12 at 20:25

In the BIOS check if you have enabled with PXE checked, if so change it to just enabled.

Check to see if there is any option for WOL on the NIC, if so disable this, download http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php - you can get an updated driver from here (11/02/11). Uninstall the driver and ensure that you delete the install files as well.

If that doesn't work there is a BIOS update A05 you can get here - http://www.dell.com/support/drivers/us/en/19/DriverDetails/DriverFileFormats?DriverId=4V3H5&FileId=2852183655.

  • Thanks for the hints. I'll pass that along to our desktop support team. – Yanick Girouard Apr 24 '12 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.