In excel, we can insert date using "CTRL ;" shortcut, but the date inserted are in "M/d/yyyy" format. I want to insert date in the "d-MMM-yy" format them I've re-config the Region and language as below, but it doesn't help. Anyone know how to insert date using hotkey with custom format ? Please share! Many thanks! enter image description here

Thanks Bob for quick answer, but it's not what I looking for, cause I often use Ctrl+; in the excel comment then I need another tip for insert the date.

2 Answers 2


The date format in Excel depends on how the cell is formatted:

Screenshot of format cells box
Click for full size

  1. Select the correct format for the cell(s).
  2. Enter the date with Ctrl+;.
  3. It will appear with the default format. Leave the cell (arrow key, enter, tab, click out, etc) and the format will update automatically.

You can also adjust the formatting after inserting the date.

  • This only works in the situation where what you are storing in the cell is a date value. It doesn't work for when you're putting free text into a cell and want to include today's date as part of this free text, or as the asker says when writing the date in a comment.
    – Stewart
    Oct 22, 2020 at 13:03

You will need to change this under Windows Region and Language Setting. (It is not a setting in Excel)

Go to Control Panel --> Regional and Language

Change the "Short date:" to the format you desire from the drop down menu.

  • the OP already changed that, as seen from the screenshot in the question
    – phuclv
    Nov 21, 2019 at 4:22
  • But it doesn't make sense to go through all this just to enter a date in a specific format in an Excel file. It's much quicker to type the date manually.
    – Stewart
    Oct 22, 2020 at 13:10
  • Just realised the stuff posted here may not be completely clear. I make out the problem this question was trying to solve is to insert today's date, within a textual cell value or comment, in a format that is not the same as you generally use (meaning it doesn't make sense to change it in the Windows regional settings). On this basis, it seems the best thing you can do is type the date manually.
    – Stewart
    May 15 at 10:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .