30

When I lock my Windows 7 Pro 64bit desktop and then unlock it after the screen saver has activated I find that all of the windows that were on monitor 2 (right side) have moved to the lower right of monitor 1 (left side). Also all of the windows on monitor 1 have moved to the lower right as well. I have tried various adds and removes of the monitors with no luck.

  • 1
    How are the monitors connected? What is the video adapter in use? This isn't normal behavior for standard digital connections, and it sounds like when that happens one of the outputs is actually getting disabled in software. Or possibly it's going to sleep and the output one adapter is on wakes up faster than the other (so it rearranges the windows in the meantime) – Shinrai Apr 6 '12 at 21:03
  • 1
    The graphics card reports as an Intel Q45/Q43 Express Chipset. 1 display is DVI and 1 display is VGA. There are 3 ports on the card, once I have the cable I will try the display port. DVI is running 1920x1200 VGA is running 1280x1024 – Andy Apr 9 '12 at 15:06
  • This is happening to me as well, did you fix it? – jcollum Aug 10 '12 at 20:37
  • +1 same problem here. I have an NVIDIA Quadro NVS 420 GPU, which is probably the problem. This card is designed to support up to four displays with a dongle. My two displays are currently hooked up to ports 1 and 2, which are on separate dongles. I suspect moving them around could help. – Elliott Jun 5 '13 at 19:51
  • Windows 10 as well. – johntrepreneur Jan 24 '17 at 19:24
17

I had the same Problem, the Problem comes from the Power Saving Settings. If there the Monitors are send to suspend, then on wake up not all monitors wake up at the same time and so windows arranges all windows on the first monitors to wake up. Set the power saving settings for monitors to never and the problem is solved.

  • 4
    In Win10, search for "Power & sleep settings", change both screen options to 'Never'. – Robert Gowland Mar 13 '17 at 12:38
9

An NVIDIA graphics card may fail to read the EDID info from the monitor when returning from a standby mode. You can fix it by setting your monitor settings from a file with previously saved EDID info.

  1. Start NVIDIA Control Panel (e.g. by typing in that name into the search field).
  2. Open the "View System Topology" task.
  3. Click EDID source. We will change the value from Monitor to File. (the screenshot shows the end situation after step 7) View system topology
  4. In the manage EDID dialog click the "Export" tab.
  5. Export the monitor settings to a file from the monitor you want to "hard-wire" the settings. This prevents the resizing/moving windows. Export EDID file
  6. Change to the "load" tab.
  7. Load the just exported monitor file and select the same monitor to apply the fixed settings. Then click the "Load EDID" button. Load EDID file

Done.

Idea from https://sites.google.com/site/ebobster/stuff/displayportblanking

  • Not a fix, more a workaround. – Little Helper May 4 '15 at 10:31
  • 1
    Yes, it's a workaround. But that's ways better than nothing at all. – Tobias Weibel May 5 '15 at 10:49
  • 1
    My NVIDIA control panel doesn't have that "workstation" node on the tree. – johntrepreneur Feb 7 '17 at 17:28
  • Works great for me. – Stabledog Jun 29 '17 at 16:48
  • @LittleHelper a real fix would be to replace the NVIDIA graphics card, but we still do not know if the root problem is with NVIDIA or Windows, or DisplayPort, or the monitor itself. This answer works for me: Win7, Nvidia, Displayport, Lenovo X1 4k monitor. – Roland Feb 22 '18 at 15:18
4

The symptoms of windows shrinking this way indicate that a change in resolution occurred. When the resolution is set or changed to lower, the windows are shifted around and shrunk to fit that resolution. Either that or a person could lose access to them and have to reset their postition because it opens off screen (We had that before also) when in low res.

Screen savers or the log-in screen can exist at a lower resolution can cause this problem. In windows 7 the log-in screen can match the res of the desktop under normal/proper operation, so check for the screensaver issue first.
Test first by doing lock with "None" screensaver, and see if it still happens. Try and get the screensaver to match the resolution or find one that does?

  • Tried it with screen saver set to <none> and blank. I did not mention before, but the system is power saving the monitors also. – Andy Apr 6 '12 at 21:48
  • @Andy I figure you might have, what is the res that the log-in is shown in? It is beyond what I understand , but it has been mentioned in passing that the log-in screens can be set for different resolutions. Maby some registry setting? On dual monitor standby, my system standbys the monitors without messing anything up? Are the Duals on the same video card/driver ? Could it be there is some mixup with the video cards drivers, that they are working fine, but some aspect of thier operation, or a Service that has been stopped that would be doing any extra actions required on the event. – Psycogeek Apr 6 '12 at 22:03
2

You MUST use DVI ! DP and HDMI are "Plugable" Displays in Windows. After the Monitor goes into Power-Save - Windows lost all Infos about the screen and "Think" it's unplug. This is why all windows swap to Screen 1.

Google, there is a "hot-fix" for DP/HDMI where some contacts eliminated to prevent this. Microsoft would not help you. There are thousand of peoples out there with exact THIS problem, but Microsoft does not care.

If you use DVI - Windows did not interpret this as plug screen. All fine.

0

I'm not sure if this helps any more but I had the same problem with a 4K external monitor plugged in by displayport. And this poste resolved the problem.

https://superuser.com/a/1021868/176363

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.