36

I use Notepad++ as a text editor. Whenever I open any text file, Notepad++ shows two virtual characters CR and LF at the end of each line. These characters are annoying in some cases, e.g. when reading application logs.

How do I remove or configure the display of these characters?

48

Toggle the setting View > Show Symbol > Show End of Line

As Xenorose notes, Show All Characters should also be unchecked.

Screenshot of setting
Click for full size

  • 2
    You got there a few seconds before me. :) it should be noted that it might be the "all characters" that's marked. – Eran Apr 8 '12 at 9:00
  • 1
    i dont have that option checked, but LF is still showing. If i toggle the option, i get LF and CR, if i turn it off again, im back to just LF at the end of the lines. is this a bug? – mack nordstrum Aug 29 '14 at 21:35
  • 8
    hmmm, i saved the document and closed notepad++ then re-opened it, and the LFs went away, must have been a temporary glitch – mack nordstrum Aug 29 '14 at 21:46
  • I also had this what you call temporary glitch. – René Nyffenegger Sep 13 '16 at 6:43
7

In the menu go to :
view > Show Symbols
You probably have one of these checked: "Show end of line" or "show all characters" . Uncheck them (only one can be selected, deselect the one you have checked).

5

If you are seeing something like this (Block carriage return (CR) and linefeed (LF) characters after pressing 'Return' or 'Enter' key on the keyboard):

enter image description here

You can fix it by clicking the ¶ icon on the toolbar.

enter image description here

  • 1
    This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Nov 16 '16 at 23:49
4

Just to add to the answer, there is also an Icon on Main Notepad++ interface to disable/enable these special characters.

Disabled

Notepad++ show characters

Enabled

Notepad++ show characters - enabled

It saves about two mouse clicks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.