Trying to get my transmission-daemon to pick up files from a dropbox folder, to make remote starting easier (it's a headless system).

As far as I can tell, the settings.json file is as expected, but none of the files I place in the folder get picked up.

I have checked that dropbox is syncing correctly.

Here is the whole settings.json file, but the relevant lines are included below:

  "watch-dir": "/home/john/Dropbox/torrents",
  "watch-dir-enabled": true


It appears to be a permissions issue. From /var/log/syslog:

Unable to watch "/home/john/Dropbox/torrents": Permission denied (watch.c:79)

I have tried stopping the daemon -> sudo service transmission-daemon stop -> changing permissions of folder using chown -> sudo chown -R john /home/john/Dropbox/torrents -> restarting daemon -> sudo service transmission-daemon start

Same result, however

Update 2

Permissions for the folder are:

drwsrwsrwx 2 john debian-transmission 4096 2012-04-09 19:40
  • Transmission doesn't run as your user, so chowning the files is useless. Try chmod go+rw instead. – Daniel Beck Apr 9 '12 at 8:22
  • what is that doing? – Mild Fuzz Apr 9 '12 at 12:09
  • chmod -R go+rw filename gives read/write permissions to all files' group members and everyone neither a group member nor the file owner for the given filename and, recursively, for everything it contains. You should try to find out as what user Transmission is running, then you can give that user, specifically, permissions to that folder and everything in it. Also, in case that's your real pass phrase in the JSON, consider changing it now. – Daniel Beck Apr 9 '12 at 12:23
  • It's not, although the sentiment is accurate ;) – Mild Fuzz Apr 9 '12 at 19:13
  • Tried, same result in the syslog. I have included the folders permissions in the second update – Mild Fuzz Apr 9 '12 at 19:17

The solution is to give your dropbox folder permissions of 775

sudo chmod -R 775 ~/Dropbox

For those landing here : you must edit /var/lib/transmission-daemon/.config/transmission-daemon/settings.json instead of the one in ~/.config/transmission

Specifically tested on version 2.92, you have to stop transmission-daemon service before editing the settings.json. Otherwise, upon service restart, all changes made are rolled back. Weird, I know but don't ask me why.

The catch is that the last transmission-daemon folder is permission locked, so edit the settings.json with an absolute url

sudo nano /var/lib/transmission-daemon/.config/transmission-daemon/settings.json

And of course, restart the service

sudo service transmission-daemon restart

I had the same issue, but any solution did not help me until I moved torrents folder from external disk to internal. After that everything works just fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.