0

I installed Linux Mint 12 on my Dell Studio 15 and everything worked perfectly up until I tried updating the STA Driver for the Broadcom (BCM4312) wireless controller.

I've tried these bash commands in order and I still don't have wireless.

sudo apt-get install b43-fwcutter
sudo apt-get install b43-fwcutter firmware-b43-installer

I've also tried uninstalling everything with synaptic package manager including broadcom-sta-common and broadcom-sta-source, then restarting and running the above commands which didn't work either.

What's the best way to do this on a Dell Studio 15?

1

Solved: I found this thread in linuxmint forums. This solution is meant for LMDE but I can confirm it works with KDE as well. http://community.linuxmint.com/tutorial/view/218

0

I was able to do something similar using Ubuntu on my Dell Inspiron using Synaptic Package Manager, however I had to browse inside of the GUI of SPM to get it done.

I had to plug into an ethernet jack to get internet access. I also updated the OS via an update manager and restarted...

When I opened up SPM, I searched for broadcom drivers, and doing so I could only get results for searching "bcm". A few things would show up including bcd-kernel (something similar to this) and also something along the lines of firmware installer & fwcutter.

I uninstalled and reinstalled these (sometimes it appeared they were installed, for some reason) then upon restarting the system, my wireless card could access networks.

I hope you figure it out. This was really frustrating for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.