23

I have a word document containing images and tables. These have captions which are numbered, like "Image 1-Example of something". Later on I decided to rearrange some of chapters of my document. However numbering of objects remained the same, so the first image is image 8, the second is image 3, etc.

I want to force Word to recompute image numbering so first image in document would be image 1, the second - image 2, etc.

Is that possible? Will references (added through cross reference feature) to those objects be updated?

1
  • Can't imagine this would work, but have you tried copy/pasting the entire document to a new one? – Jonathan Payne Apr 9 '12 at 20:52

12 Answers 12

31

You need to update all references in your document. To do so select all of the document (Ctrl+A) then press F9.

3
  • 3
    If you have a list of figures in the document, you need to press F9 twice, first to update the figure numbers, and then again to update the list properly. – Jezzamon Oct 28 '16 at 11:49
  • Is there a way to automate when opening document/every X minutes? – BND Sep 26 '20 at 9:45
  • 1
    OP, can you please accept the printing answer as the accepted answer? I think that seems to be the universal solution and fixes problems that my solution don't. – RJ- Sep 26 '20 at 11:45
11

Word 2011 for Mac updates these field values for the whole document before printing. You don't actually have to print the file but just open and close the print dialog via File --> Print... --> Cancel. Don't know if this works for all versions.

5
  • This worked for me whereas command+A, then F9 did not do anything. I just printed as a PDF and magically all the figures were correctly numbered (Word Mac 2011, 14.4.9) – orbeckst Jun 5 '15 at 6:35
  • This worked for me also, where command+A then F9 didn't work. F9 fixed the cross-references to the figure numbers, but it didn't reorder the figure numbers themselves. This trick did. Thanks! – Brionius May 2 '19 at 23:58
  • 1
    Crazy, this still seems to be the only way to force a reload for label... – Rico Sep 17 '19 at 8:43
  • 1
    Works on Windows - lifesaver! tried F9 and it did nothing, ctrl+P then return and all is fixed! – Euan Smith Mar 8 '20 at 16:46
  • As of 6/2020 still working whereas the Select All method didn't work – Ashaman Kingpin Jun 2 '20 at 20:20
4

I've just come across a scenario where Word had decided that the second figure in my document was Figure 1, and that the first one was Figure 2, and that there was nothing I could do to persuade it otherwise.

The eventual solution turned out to be,

  1. Select the second figure and its caption and cut it.
  2. Update fields with F9.
  3. Paste the figure and caption back in.
  4. Update the field in the newly-pasted caption.
  5. Fix the inevitable resulting formatting SNAFU.
2
  • This situation is ridiculous – Thomas G. Mar 8 '20 at 9:31
  • @ThomasG. yup... – Flyto Mar 8 '20 at 13:12
2

If Track Changes are turned on and tables, figures, and associated captions have been modified, I found I had to accept those changes before the suggestions above worked.

1
  • This turned out to be very useful for me. I had deleted a floating shape containing a Figure caption with Track Changes turned on. The figure caption was still kept in the document, and was causing an "invisible" figure number to stay in the document at the point of deletion. – Jace J McPherson Oct 23 '18 at 22:46
2

I know this might seem late and old, but I would like to share this:

I double clicked/selected the number only (If it is Figure 2, then double click/select the "2"), after that I right clicked and in the pop up, there was "Update field", I clicked this and the figure got updated.

I think the only downside in this is you must do for each figure/table, but it works.

Frank

1

To update the things containing references, like the table of contents or cross-references, select the document contents and press F9.

Of course, this will not work if you numbered the captions by hand, instead of letting Word do the counting.

1

Update field may not always be linked to F9. In some cases the shortcut is shift+alt+cmd + U, though right clicking generally works

1

Ctrl-A then F9 will only work if you have added the captions using the add caption option when right clicking the image.

If you have added lines manually saying

Figure 1 - blah blah

then Word won't renumber them, because they are just another line of text. You can tell which captions are added and managed by Word and which one aren't by toggling on field codes. I do this by hitting Ctrl-A, then right clicking on a caption or blank area and clicking "toggle field codes".

Captions which have been created by Word will now look something like

Figure {SEQ Figure * ARABIC} - blah blah

instead of having a number. If your captions do not show this, then Word won't renumber them. So erase them and replace them with captions created using the Insert Caption option.

0

I had to combine the answer given by bytesum with the other solutions.

  1. open the print dialogue (updates the numbers in the captions)
  2. select all and press F9 (updates the references to these captions)

edit: i am using word 2011 (mac)

1
  • Why would you open the print dialogue to update image numbers? – HelloGoodbye Aug 25 '16 at 9:25
0

The other way in case your F9 key doesn't work (i.e. remote desktop to pc platform from a mac) use Ctrl+A then right click and select "update field !"

0

First you need to select all and only images :

let consider your images have caption starting like this : "Figure #nb ",

  1. Select the world Figure from any caption you want,
  2. go to Home tab,
  3. Editing->Select->Select text with similar formatting,
  4. press the F9 keyboard.
0

Track changes does indeed interfere with updating figure caption numbering after moving or deleting figures. All of the instructions to F9, Alt-F9 and Shift-F9 or printing had no effect. Very frustrating.

Still then, I found that the removed reference stays invisibly on the page, so the table of figures continues to index it. I had to remove the text around the previously location to fully get rid of the embedded and invisible reference code. I then re-entered the text manually to be sure I didn't reinsert it.

I also had some XE index references displaying in the text (but only in one set of headers) and could not toggle them out while Track Changes was active.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.