I recently bought a Samsung SCX-4623F Printer-Copier-Scanner-Fax machine. Printing and copying work fine, but I have been unable to scan anything with it.

The device is connected to a PC running Windows 7. It is shared in my home network, specifically with a laptop running Windows XP (which has the Samsung software from the CD that came with the device - the PC just automatically downloaded the drivers).

I tried several options:

  • I put the device into scan mode and I can "choose" between one option: Scan to PC. When I click it, it let's me "choose" again "Local PC". When I click that, it says "Connecting..." for a few seconds and then "Not Available". enter image description here
  • I tried scanning through the Windows 7 printer/scanner screen, and I get the following error: enter image description here
  • I tried scanning from the Samsung software through the Win XP machine, and I get an error stating something like (the original error is in Hebrew, so it's not exact) "The scanning device is not responding".
  • I tried combining clicking the scanning software (both Win 7 / Samsung stuff) with clicking the scanner to scan to local PC, with same results.

How do I scan with this thing?

  • 1
    Those errors are slightly better than "PC LOAD LETTER", but not by much. – aportr Apr 18 '12 at 14:09

The Microsoft answers forum has a similar problem, solution being you need to enable Windows Image Acquisition (WIA) service.

  1. Open services. (Start -> Run -> services.msc OR right click on My Computer, select Manage, then select services.)
  2. Find Windows Image Acquisition (WIA)
  3. Set it to start automatically.

It may prompt you to also start other dependant services, e.g.:

  • Remote Procedure Call (RPC)
  • DCOM Server Process Launcher
  • RPC Endpoint
  • Mapper Shell Hardware Detection

One thing to note for further troubleshooting is that the WIA service runs as LocalSystem on Windows XP, but as LocalService on Windows Server 2003 and Vista (and Windows 7 I would presume), which might confuse confuse old drivers.

  • Now it works on my Win7 machine, thanks! (though it still doesn't work on the XP one). – Amir Rachum Apr 19 '12 at 8:52

Sounds like a driver issue. Try completely uninstalling the device and downloading the latest drivers direct from the manufacturer.



it might also be because your computers printer spooler isn't functioning properly. It happened to me because i was using a program that sped up my computer by closing things i didn't need at the time.

  • printing works just fine. – Amir Rachum Apr 18 '12 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.