I want to do share some videos I've made with friends on IRC, and it would be easiest if I could just stream it so we can all watch at the same time and critique parts of it in real time. Has anyone done something similar?

VLC will say that it's streaming, but I'm unable to connect to it locally (within the network or even on the same computer), and ffserver just tosses me an error. Streaming from the command line has almost no official documentation for VLC, but something I did find was that Debian apparently strips the encoders from the vlc package.

I've tried ffserver with ffmpeg, I've tried VLC, and I'm not sure what else to try or what I've done wrong.

I've gone through, with VLC

$> vlc --version
VLC media player 2.0.0 Twoflower (revision 2.0.0-0-g421a4fc)

and tried everything I could in the streaming section, but I can't get the stream to actually work.

Linux s10 3.2.0-2-686-pae #1 SMP Tue Mar 20 19:48:26 UTC 2012 i686 GNU/Linux

Basic home network, I am behind a NAT (192.168.1.*) and have dynamic DNS set up. That doesn't really matter too much, I can figure that out, but it's not even working locally. I have a file server set up and could just share the files that way, but I'd rather have everyone watching at the same time (or just about). Not worried about installing new packages or building something from source, that's not a big issue, just want to get it working. Big plus if I can do it from command line.

What I get while trying to use ffserver (ffmpeg.com/ffserver.html):

$> ffserver -f .config/ffserver/ffserver.conf & ffmpeg -i videos/myvid.avi http://localhost:8090/feed1.ffm
ffmpeg version 0.8.1-4:0.8.1-1, Copyright (c) 2000-2011 the Libav developers
avserver version 0.8.1-4:0.8.1-1, Copyright (c) 2000-2011 the Libav developers
  built on Mar 19 2012 09:20:10 with gcc 4.6.3
  built on Mar 19 2012 09:20:10 with gcc 4.6.3
This program is not developed anymore and is only provided for compatibility. Use avconv instead (see Changelog for the list of incompatible changes).
Wed Apr 11 10:16:40 2012 Codec sample_rate, channels, frame_size do not match for stream 0
Wed Apr 11 10:16:40 2012 AVserver started.
[mp3 @ 0x9d3c560] Header missing
[mpeg4 @ 0x9d3bac0] Invalid and inefficient vfw-avi packed B frames detected
Input #0, avi, from 'videos/myvid.avi':
    encoder         : Nandub v1.0rc2
  Duration: 00:45:47.57, start: 0.000000, bitrate: 1068 kb/s
    Stream #0.0: Video: mpeg4 (Advanced Simple Profile), yuv420p, 624x352 [PAR 1:1 DAR 39:22], 23.98 tbr, 23.98 tbn, 23.98 tbc
    Stream #0.1: Audio: mp3, 48000 Hz, stereo, s16, 135 kb/s
Incompatible sample format '(null)' for codec 'mp2', auto-selecting format 's16'
Incompatible sample format '(null)' for codec 'libmp3lame', auto-selecting format 's16'
Wed Apr 11 10:16:40 2012 - - [GET] "/feed1.ffm HTTP/1.1" 200 4149
[buffer @ 0x9d43ca0] w:624 h:352 pixfmt:yuv420p
[scale @ 0x9d3d4c0] w:624 h:352 fmt:yuv420p -> w:160 h:128 fmt:yuv420p flags:0x4
Cannot read file 'ffmpeg2pass-1.log': No such file or directory
Error reading log file 'ffmpeg2pass-1.log' for pass-2 encoding
Wed Apr 11 10:16:40 2012 - - [POST] "/feed1.ffm HTTP/1.1" 200 0
  • Are you behind a NAT? More details on your setup would be helpful... – Garrett Apr 11 '12 at 4:30
  • lots of text, still: what are you trying to achieve? stream a file .. from where? to where? first explain the problem .. and THEN all the (relevant) stuff of the things you tried. and i mean literally "first" .. in the first few sentences. not somewhere digged underneath command line junk. – akira Apr 11 '12 at 14:23
  • Going to try building VLC from source and see if that changes anything. From what I understand VLC is a bit of a pain to build though. A lot of things installed from build-dep vlc though, might just work if I reinstall it from apt-get now. – Rob Apr 11 '12 at 14:41

apt-get build-dep vlc and going through the regular streaming wizard for vlc worked perfectly, now I just have to figure out the command line for it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.