I am trying to boot BAMT, a Linux distribution based on Debian via USB on a brand new Gigabyte GA-970A-UD3 motherboard. I tried various flash drive and various OS. I never had this problem with ASUS and MSI. The problem is from Gigabyte hardware.

I found that my BIOS is very strict about MBR compatibility. Now, I can boot in DOS mode. The flash drive needs to be formatted as a Windows 98 Startup Disk using the HP USB Disk Storage Format Tool.

Unetbootin creates bootable USBs, but it doesn't support BAMT. If I use the Windows or Linux disk imager, the working MBR is deleted. I tried converting the BAMT .img to .iso, but it still doesn't boot from Unetbootin.

Is it possible to boot BAMT (Debian Linux) from a Windows 98 DOS command prompt? Maybe some way to burn the image and use the working MBR instead?

Remember that if the working MBR is not used, the flash drive is not recognized at all by the BIOS.

This is the info I found that got me booting for the first time in DOS:

GB's BIOS will only boot USBs formatted to FAT-32, conforming to normal MBR bootloader. I've seen this before, and surmised that the 'stick-maker' was formatting in ReiserFile, or one of the EXT 'flavors', but no one ever followed up to confirm or deny... Also, if it's putting the bootloader into its own partition - won't work!

In the BIOS, on the "Integrated Peripherals" page, the "USB Storage Function" item must be enabled (which should be the default) to allow USB booting...

I've put a little work into a 'GB USB booting tutorial', and frankly, I'd just go ahead and finish it up for you, but I really don't want to reboot the several times it will take me to 'firm up' procedural details, and take the BIOS/boot pictures for the post - just noticed VAIL finally went 'public beta', so will be downloading for likely twenty-six hours or so There's likely enough there to test a 'raw DOS boot', just to see if your hardware (especially the USB stick itself) will do it...

Some post later:

Fixed. Here is a brief summary. Since my ubuntu live usb sticks (2gb kingston and 8gb sandisk sd/usb reader - fat32, created in ubuntu 10.04) would not boot this board even though they would boot my ga-ep45-ud3p, I decided to try bilbat's suggestion with the HP usb boot program. I created the win98 boot disk on the kingston 2gb stick without reformatting. It booted right up. Next, I used windows version of unetbootin to write the ubuntu live cd to the kingston disk. This fired right up and completed the install. Everything seems to be in good order now.

Unfortunately, I can boot in DOS mode but can't boot to BAMT.

EDIT: I can run Debian but not BAMT.


Try using PLOP bootmanager to boot from usb on your motherboard. This bootmanager can be burned to a CD or copied on USB or diskette


| improve this answer | |

It's kind of dangerous to do it this way, but I found it to work.

Update your BIOS.

I went to Gigabyte's Website to download the latest BIOS version. Download F8a (currently is the latest version) and run the self unzipper, and forget about everything but the .f8a file. Copy that file to a flash drive and restart your computer, with the flash drive plugged in.

When you come to the Award Bios Screen, open up QFlash, and make a backup of your current BIOS configuration by choosing to save it to your flash drive. I would suggest BIOS_Working or something as such.

After saving it, then run the upgrade utility and choose the .f8a file you put on your flash drive. This is very dangerous, but also the only way I got it working. It should finish successfully, and when it does, you should be able to boot from a USB-HDD without needing to run any extra programs. It just worked for me. (I was installing Ubuntu 12.10)

| improve this answer | |

I also own the 970A-UD3 and a Window 7 install flash drive.

I couldn't for the life of me get it to boot from the drive itself. I found if you have Windows Vista or 7 installed already you can boot to the repair screen by tapping F8 during boot.

You'll get options like repair my computer, safe mode, safe mode with networking, etc, etc. Select repair my computer and cancel the scan thing that pops up after the user select screen. Go to advanced repair functions where you can get to command prompt.

Inside command prompt you can navigate to the USB flash drive. Example cd e:\, E being the flash drive. Once you're on the flash drive you can run executable programs through the command prompt. So once your on e: drive type setup.exe for people installing Windows from a flash drive. The "Install Now" screen will pop up and you can install Windows from there.

Not sure if this trick will work with Linux systems or not but it might be worth a try. You might also be able to do this also with a Windows vista/7 install disk if you don't have Windows already installed. I had to do this as the new motherboard and CPU wouldn't boot my old install from my hard drive.

| improve this answer | |
  • This will work for anything that you would have to do that's Windows Related. Unfortunately, the reason for this is that once you get to this point in the boot sequence, you've already loaded the OS (Windows) which means you're past the point that you can boot from a different USB. – Goldentoa11 Sep 13 '14 at 14:16

The problem is that this specific motherboard has IOMMU support disabled by default.

To solve this, go into the bios settings and turn it on.

Debian boots just fine once this is done.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.