1

I am trying to setup Firefox for Automatic Windows Authentication in Firefox 11 on my local Windows computer (Workgroup, not part of a Domain). I have edited the network.automatic-ntlm-auth.trusted-uris setting to include "http://localhost/reports" and I have also tried the expanded address "http://localhost:80/reports/Pages/Folder.aspx" but neither works. I am still getting the pop-up asking for me to login.

Does anyone know how to fix this?

-2

Follow instructions here https://docs.secureauth.com/display/KBA/Enable+Integrated+Windows+Authentication+%28IWA%29+in+Mozilla+Firefox or here https://specopssoft.com/blog/configuring-chrome-and-firefox-for-windows-integrated-authentication/ or here https://stackoverflow.com/questions/11096826/ie-firefox-with-integrated-windows-authentication

  1. Open Firefox.
  2. In the address bar type about:config
  3. You will receive a security warning. To continue, click I’ll be careful, I promise.
  4. You will see a list of preferences listed. Find the settings below by browsing through the list or searching for them in the search box. Once you have located each setting, update the value to the following:
    network.automatic-ntlm-auth.allow-proxies True
    network.negotiate-auth.allow-proxies True
    network.automatic-ntlm-auth.trusted-uris
    Double click on the setting and enter the website address. If you have more than one separate using a comma. You can ommit the transport protocol (http or https). For example intranet.local,intranet. Note: you can also enter .local if you want to apply this to all websites that match *.local
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Feb 22 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.