0

I have my development server on localhost, currently using Wamp Server.

I have setup port forwarding on my router (I used a similiar configuration for game servers and it works for them).

I set listening in http.conf to port 8080, no firewall is blocking Apache, and allowed access to All in http.conf for Directory F:/wamp/www. I still can't get it working. Server runs properly for localhost, but I cannot access it from the internet via my global IP.

I have dynamic IP, but that not a problem since I will just tell clients the current IP each time it changes.

2
  • What happens when you try to access it? – tyjkenn Apr 13 '12 at 1:28
  • via browser it says that it couldn't connect to host, via portchecker it says it could not see service on port 8080, and for reason: connection timed out. – pawel-kuznik Apr 13 '12 at 8:35
1

If it works on LAN but not on WAN, then you may need port forwarding.

This is common if you have a cable modem or something that doubles as a hardware firewall.

If so, this is how I would fix it on mine, and it should be similar to yours:

First, press WINKEY then type cmd then in the Command Prompt, type ipconfig /all. Record the IPv4 Address for your computer. It will be like 192.168.0.10 for example.

IPv4 Address. . . . . . . . . . . : 192.168.0.10(Preferred)

That is your computer's address on your LAN. Let's say your WAN IP is like 24.100.50.200 and your Wampserver is setup on port 1337. You would expect it to work via http://24.100.50.200:1337 but it doesn't.

Your goal now is to forward port 1337 in your firewall to 192.168.0.10:1337. This makes sense because imagine you had like 5 computers. How would your modem/router know which one to send traffic to?

Now:

  1. Open browser
  2. Go to http://192.168.0.1
  3. Login as admin
  4. Find port forwarding
  5. Enter your IP: 192.168.0.10
  6. Enter the port: 1337
  7. Forward TCP there (or UDP as well), but just TCP should do it (dont quote me on that)
  8. Save
  9. Make sure it saved, sometimes those admin areas troll you
  10. Try to connect again via your WAN IP and port.
0

You're problem is most likely not WAMP, or your router at all.

When trying to figure out this same exact problem a couple months ago, I found out that even though the router was forwarding my IP to the modem, the problem was that my modem was not forwarding connections (on port 80 in my case, but same deal with 8080) to the router. In turn, the router would forward to my server.

Here's what you should do:

  1. Take a look at your modem (which was located at 192.168.2.1 in my case) and look for

    NAT (Network Address Translation)

  2. Type in your router's IP (which was located at 192.168.0.1 in my case) and the port which you choose to forward requests to (which is 8080 in your case).

  3. Save those settings, and try again!

Hope this solves your problem! If it does, be sure to accept it as the answer to your question.

You might look at my question here and my chat regarding it here as an extra resource.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.