I have two Vista Ultimate 32-bit OSs installed on my PCs here (one desktop for about 3 years, the other a laptop for 1 year), and have been experiencing the following rather irritating problem for a while on both of the computers:

Right-clicking on any shortcut in Windows, be it in Windows Explorer, the desktop, or the Start Menu, and then selecting Run as Administrator has absolutely no effect. I am of course running on an administrator account, and the expected behaviour should be for a UAC prompt to appear to confirm the execution of the given program.

This is persistent behaviour which I have not since been able to eliminate, even temporarily, on either of the installations. It is worth nothing that the issue appeared only a number of months after setting up the OS, and is quite possibly due to a program I installed at some point on both machines, which has corrupted something (perhaps a registry entry) that prevents the Run as Administrator action. Unfortunately, since I've virtually mirrored the OS configuration and programs installed on both PCs, there is no real possibility I can determine which setup program caused the issue by cross-comparison.

I have described exactly the same problem here on the MSDN forums, which some feedback, but nothing close to a solution unfortunately. The only real recommendation I received in the end was to wipe and reinstall, which is not a feasible solution for me.

Any suggestions here, even long-shots, would be most appreciated here, as I am getting fairly desperate for a resolution.

  • have you tried turning UAC off, then back on? – John Gietzen Sep 14 '09 at 20:10
  • @John Gietzen: Nope, haven't tried that yet. Sounds like a longshot, but I'll give it a go anyway. Thanks. – Noldorin Sep 15 '09 at 12:06

Right click on the shortcut icon and select properties. Put a tick in the box for "Run as Administrator".

If you have the original Windows DVD you can open a command prompt as administrator (if you can still do that) and type SFC /scannow This will check your install for corrupt system files against the install DVD and repair anything that is damaged.

  • Configuring the shortcuts to always 'run as administrator' would do the job, except I usually only want to run them in unelevated mode. Thanks for the tip about the scan for corrupt system files. Will reply with the results of that. – Noldorin Sep 15 '09 at 12:07
  • @MarkM: Just tried running the 'SFC' utility, and no luck resolving the problem. However, it did say that the search had found corrupt system files, and produced a rather large log. If you feel this would be of any relevance, I woudl be glad to upload it. – Noldorin Sep 16 '09 at 10:29

I have had success by going to the actual .exe file (not the shortcut) and changing its properties to 'Run as Administrator'. For some items, this has produced a different result than changing the property on the shortcut.

  • This is pretty much my current work-around. Well, in fact just right-clicking on the EXE (rather than shortcut) and selecting 'run as administrator' does the job. Not terribly convenient however. – Noldorin Sep 15 '09 at 12:08
  • After I have changed the properties on the .exe, then when I make a shortcut to that .exe, it runs properly (as administrator). – Stewbob Sep 15 '09 at 20:08

Interestingly (and thankfully) this problem seems to have fixed itself after one of the recent Vista updates. On both computers I can now run any shortcut as administrator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.