I have a WD Elements 2TB hard drive (formatted NTFS). I accidentally kicked out the USB cable while writing data to the disk, and now I can't access most of the data. Although this was ostensibly my backup drive, there is a great deal of important material on there which was only on there. I realise how idiotic this makes me. (So, formatting is not an option.)

Things I've tried/information I've gathered:

  • Windows Explorer will recognise the drive itself. However, it will not access most directories therein (and will sometimes crash when exploring). I can access all of the directories through the command line, but the dir command will often report that it can't read any files in most of the directories. The situation was similar when I hooked it up to an Ubuntu machine: the file explorer crashed, but I could access directories - but not files in those directories - via terminal commands. Several files I tried to copy out either resulted in an I/O error being reported or resulted in the command line crashing.

  • The Disk Management utility on Windows reports a healthy disk formatted as NTFS and not RAW. It also indicates the correct amount of space used up and its capacity (so it seems that the files are not deleted).

  • I've tried to run chkdsk, but that hangs on Step 2 (checking indexes) at 74%. Step 1 reported no bad sectors.

  • I tried Recuva, but that didn't seem to work (stalled at 0% for half an hour).

  • I should also note that the disk doesn't seem to be spinning smoothly; it seems to be chopping back, like it's reading the same sector over and over again. I noticed this after I kicked out the cable.

Update: It would seem the problem has taken a turn for the worse. The external hard drive now shows up on my computer as a local disk and is not mountable by Linux.

  • 1
    Time for professional recovery before you hose it completely. – Moab Apr 14 '12 at 23:15

You could try Testdisk - It can recover damaged partitions. It is pretty daunting to use first time around so you really need to have access to their website while using it.

  • Used this to recover tons of digital photos when the file server crashed. Comes with another utility that will read the EXIF info from the files and sort them for you. – Sarge Apr 15 '12 at 1:14
  • Hi BJ292 - Testdisk gave me some measure of success. I was able to access my directory tree again and copy out some files. Other files couldn't be read, or they copied over as 0 byte files. I'm going to see whether Photorec (packaged with Testdisk) is able to retrieve the files that Testdisk can't. Whether or not I get all my files back, thanks for the suggestion. :) Some files certainly beats none. – CCallaghan Apr 15 '12 at 3:48

If you really care about the data on that drive, the first thing to do is to make a disk image (exact sector-by-sector copy) of the disk onto a different disk. Running any utilities on a damaged partition/disk with important data can potentially make your problem far worse. Believe me, I wish someone gave me this advice when I had my first HDD crash.


You might be able to access the data in linux as it will read NTFS drives like they have no security at all. I recommend putting Linux Mint on a USB thumb drive and booting from it. Download the latest ISO and the Universal USB Installer app.

Stick a clean 2Gb+ USB thumb drive in, run Universal USB Installer, point to the ISO image, point to the thumb drive and click ok. Boot from this and once in Mint, see if your drive mounts as a device under the Nautilus file manager (seashell icon). It'll be under Devices on the top left. If it does you should just be able to double-click on it and drop your files to another USB drive. If it doesn't mount you could try the repair tools in Disk Utility.

This is the cheapest and fastest option I can think of without using complex PC disk reading tools which may recover things but not in their original formats and require sometimes HUGE amount of effort to make them readable again.

Anyway, if nothing else, you should know if you can get your data back within 30 mins if you try this method first. Good luck.

  • Hi hardlywired - the drive mounted without a hitch. However, Nautilus, like Windows Explorer, is failing to detect most of the files (it seems I can access some, but about 85% of the data isn't being "prepared to be copied"). Do you have any other suggestions on how I might proceed in retrieving the remaining 85%? – CCallaghan Apr 14 '12 at 6:35
  • Update: it seems that it is very slowly recognising more files (about 50% now). I'll let the operation complete and post back when it's done. – CCallaghan Apr 14 '12 at 6:44
  • Unfortunately, the copy operation produced a lot of 0-byte files. Now, the hard drive is only being recognised by Windows as a "local disk" and is not mounted by Linux. Disk management crashes when I try to examine it. – CCallaghan Apr 14 '12 at 8:58
  • Hi CCallaghan, that's a shame. Sometimes it has worked for me when nothing else will, which is why I suggested it first. Teskdisk suggested by BJ292 above might work for you but as he says, it is daunting and you will need to do some reading about it what it does before you use it. Good luck! – hardlywired Apr 15 '12 at 2:47

I'd recommend a bootable disc version of GRC's Spinrite to test for bad blocks and repair them. In my experience, nothing beats Spinrite for data repair.


It seems you have may introduced some bad sectors to the drive at some very inconvenient locations (in the middle of the MFT?). However as the drive is externally powered, I don't quite understand how any damage to the drive or even the file system is possible considering the drive would not actually lose power when the USB is unplugged.

You may have to consider the possibility that you have either damaged the USB cable or port or the drive had hardware faults long before you kicked your USB cable (tt just made it more obvious).

Use this tool from WD to check the SMART status of your disk. It's one of the few tools that can read it over USB Mass Storage.

Also, try to listen for the sound patterns your disk is making. Hard disks spin at a constant speed and won't actually stop and restart or slow down to read a faulty sector. If you think your disk is spinning up and down all the time, you probably have a faulty power adapter or circuit board.


your data is not deleted you should try chkdsk to recover

Edited ::

if chkdsk is not working i would like to recommend that you should go another way as we know none of the data is being delete even after the format only file allocation tables are being cleared so you can re fill you table to do so use testdisk-6.11.3.win this will show you the previous drives and will re fill as previous i have recovered my all data earlier when i accidently then i had successfully recovered my drives you may have the same i think thanks and regard

  • Hi Photon - unfortunately, chkdsk freezes at step 2 (checking indexes) at 74%. I figure this means that there's something wrong with the indexes that chkdsk can't fix. Do you have any recommendations on how to proceed? – CCallaghan Apr 14 '12 at 6:30
  • how long did you wait? leaving it overnight might not be a bad idea, that step often takes a loooong while – Journeyman Geek Apr 14 '12 at 6:38
  • About 10-20 minutes. My experience with chkdsk had been that it was faster, but I'll try it again overnight tonight and report back tomorrow. – CCallaghan Apr 14 '12 at 6:43
  • i think it will help you go on – Anonymous Mohit Apr 15 '12 at 3:31

protected by Community Jun 15 '12 at 7:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.