30

I am running an Ubuntu Server (12.0.4-beta2; kernel 3.2.0) in VirtualBox (host is Win7) and I want to use shared folders. I've followed the manual to set up vbox guest additions http://www.virtualbox.org/manual/ch04.html#idp5801200 but this error occurs with every startup:

Starting the VirtualBox Guest Additions ...fail!
(modprobe vboxguest failed)
Starting VirtualBox Guest Addition service VirtualBox Additions module not loaded!

When I try it myself:

$ modprobe vboxguest
FATAL: Module vboxguest not found.

Did I do something wrong, what do I need to fix it? Thanks for help.

4
  • Put some kmesg on pastebin and post the link?
    – billc.cn
    Apr 15, 2012 at 1:25
  • Thanks. How do I do this? cat /proc/kmsg doesn't write anything.
    – A123321
    Apr 15, 2012 at 9:56
  • Sorry, it should be sudo dmesg > file.log
    – billc.cn
    Apr 15, 2012 at 9:58
  • Here it is pastebin.com/TNvh9cNQ
    – A123321
    Apr 16, 2012 at 10:44

8 Answers 8

25

I had this problem today, and solved it by installing the kernel-headers

yum install dkms binutils gcc make patch libgomp glibc-headers glibc-devel kernel-headers 

then

yum install kernel-devel

or

yum install kernel-PAE-devel

Then re-run VBoxLinuxAdditions.run.

6
  • For people coming across this in the future, this did the trick perfectly for me on a fresh install of CentOS 6.2 May 16, 2012 at 23:25
  • 1
    This works because VBoxLinuxAdditions.run compiles the VirtualBox kernel modules, but doesn't quite mention this when it fails. Feb 27, 2014 at 16:10
  • 2
    Aaargh. Why do I always forget this... for Debian / Ubuntu this would be apt install gcc make linux-headers-amd64 - enjoy.
    – dualed
    Jun 2, 2017 at 16:57
  • 2
    THis doesn't work for me. Is there some other undocumented step required now in 2017? Aug 8, 2017 at 1:26
  • @MidnightJava Maybe you have to reboot after installing the kernel stuff. That seems to be the main difference between this answer and the answer below that worked for me, by wski. (for CentOS 8 at least). Sep 15, 2021 at 0:56
7

I discovered here that the standard guest additions install includes a built-in setup function, so there's no need to reinstall:

/etc/init.d/vboxadd setup

This gave me the error about missing kernel sources, so as brendan's answer, yum install kernel-devel, and then that setup command works, and everything seems to be back to normal again!

1
6

I had a similar problem today, but it turns out the vagrant-vbguest plugin was not installed. So, in the folder with my Vagrantfile:

vagrant plugin install vagrant-vbguest

That solved it for me.

1
3

on Centos 8, first run

sudo yum install elfutils-libelf-devel
1
  • 2
    Can you explain why the OP should run these commands first? Please see How to Answer and take our tour to learn how to improve your answer.
    – Burgi
    Oct 9, 2019 at 11:37
3

When installing from an ISO that has had point fixes made to it, the kernel-devel headers will most likely be a newer version than the kernel that shipped with the ISO.

You need to make sure everything is up to date and in lockstep.

What worked for me on a CentOS 8 install was the following:

  1. sudo yum update
  2. sudo yum install binutils gcc make patch libgomp glibc-headers glibc-devel elfutils-libelf-devel kernel-headers kernel-devel
  3. sudo reboot
  4. Insert VBox Guest Additions again
2

Had the same problem on a Debian guest. Based on dualed's answer:

  1. Find out your kernel architecture, i.e.:

    $ uname -r  
    4.9.0-3-686
    
  2. Install make and the kernel headers (replace "686" with your architecture: "amd64", "686-pae",...):

    $ sudo apt install make linux-headers-686
    
  3. Finally, install the Guest Additions:

    $ sudo sh ./VBoxLinuxAdditions.run
    
1

I followed till this below : None of them cleared issue. After below step, worked fine.

sudo yum install elfutils-libelf-devel

My environment: OVM : 6.1 Oracle Linux 7.9

-1

I've found this and sort everything out!:

yum install kernel-uek-headers-$(uname -r)

yum install kernel-uek-devel-$(uname -r)

it's intall what VBoxLinuxAdditions.run needs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.