1

I am not a build guru and could use a pointer. I'm trying to make php5 on linux. I have successfully run config. I run make and get the following error:

/bin/sh libtool --silent --preserve-dup-deps --mode=link gcc -DPHP_ATOM_INC -Iinclude -Imain -I/home/jspeirs/webdev/stack/php-5.3.10 -Iext/date/lib -Iext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -Iext/mbstring/oniguruma -Iext/mbstring/libmbfl -Iext/mbstring/libmbfl/mbfl -I/usr/include/mysql -Iext/sqlite3/libsqlite -ITSRM -IZend    -I/usr/local/include -g -O2 -fvisibility=hidden   -o ext/mcrypt/mcrypt.la -export-dynamic -avoid-version -prefer-pic -module -rpath modules -L/usr/lib6464 -L/usr/local/lib -L/usr/lib/mysql -L/usr/lib64/mysql ext/mcrypt/mcrypt.lo ext/mcrypt/mcrypt_filter.lo -lmcrypt -lltdl
/usr/bin/ld: cannot find -lltdl
collect2: ld returned 1 exit status
Make: [ext/mcrypt/mcrypt.la] Error 1

I know that /usr/bin/ld exists but I have no clue what -lltdl is. I have looked at the ld help docs with no insight. I have tried searching for more help with no results. If someone could help get me on track I'd appreciate it.

2

Try:

yum install libtool-ltdl-devel

And then re-run your build.

| improve this answer | |
1

check value of environment variable $LD_LIBRARY_PATH in your case it should be /usr/bin

just run

# export LD_LIBRARY_PATH=/usr/bin
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.