First, I read the other questions with similar titles and didn't find an answer.

I'm running Ubuntu 11.10 on an x86_64 machine. The guest is Windows 7. I've been running Virtualbox 4.1.12 daily since April 3. (and earlier versions before that) I ran it 2 days ago without problems. When I ran it last night, I got the message: Fatal: No bootable medium found! System halted.

I haven't changed any of the virtualbox settings. Any idea of what's wrong? Could one of the latest updates to Ubuntu have broken virtualbox?

VB is configured as:

  • IDE Controller
  • IDE Secondary Master (CD/DVD): Empty
  • SATA Controller
  • SATA Port 0: Win7-disk1.vdi (Normal, 58.59 GB)

AFAIK, it uses Win7-disk1.vdi for its disk. There is no .iso.

  • are you sure the .vdi disk is "attached"? You can check it from the virtualbox manager - file -> virtual media manager . Check the vdi "attached to:" setting.
    – WikiWitz
    Apr 18, 2012 at 1:55
  • Yes, it's attached. I've verified that VirtualBox is working by attaching the ISO for Ubuntu and installing in a new virtual machine. I made a copy of the damaged vdi and am trying to run Acronis Disk Director 11, which recovered two lost partitions. I tried running Win7 Repair, but it didn't work. In desperation, I'm going to try to re-install Win7 in the first partition so I don't lose my data in the 2nd partition.
    – Chelmite
    Apr 18, 2012 at 18:21
  • yeah that's probably the case. do you know where to find the .vdi file, though. in virtual media manager gui if a vdi is missing it will have a red exclamation icon beside it. but if it is there with no such icon, then the vdi is damaged
    – WikiWitz
    Apr 19, 2012 at 3:24


You must log in to answer this question.

Browse other questions tagged .