I use windows 7 from the beginning, so the first time when I looked into the Windows 7 Disk Defragment program and I saw the Scheduled Defrag I supposed that it worked and I did not check if it worked good...

More and more months later I had some problems running programs/games/etc and I come back there and I saw in the bottom that Last Run wasn't updated at all... So 1 month ago I manually did a defrag an all the disks re-scheduled the automatic deframentation to 1PM (the computer is always on at that time)...

But it seems to me that it never do a defragmentation.... Look at the below image..

Is this normal to not have the last run updated?

enter image description here

UPDATE After 2 Month I looked again into disk Defrag... Here's some screenshots

Defrag option enter image description here

Task Scheduler: enter image description here

The % of fragmentation on main and secondary disk is 6% and 5%, the Last Run is today becasue I started the analyze disk, but before that Last Run was the same as the System Reserved disk and the first screenshot (03/20/2012) As you can see from the last screen, the scheduler never started... Now I changed some conditions like remove the start service only if idle for 3minutes Hope this helps, otherwise any other guess?

  • If the drive is not fragmented, it may choose not to run on schedule. They all show 0% fragmentation. I run mine manually from the command prompt once a month since I do not have a consistent time my PC will be left on when I am not using it. – Moab Apr 17 '12 at 15:15
  • I got a 30% fragmentation last month... – Marcx Apr 17 '12 at 15:16
  • Change the time it is scheduled to run, maybe something else is scheduled at the same time, does the PC go to sleep or hibernate? – Moab Apr 17 '12 at 15:17
  • It's not the time... before it was on 2AM on wendsday, not is 1PM every day... the computer is not in sleep or hibernate and there are no other task scheduled for that time... – Marcx Apr 17 '12 at 15:21
  • See if there is anything helpful here...windowssecrets.com/forums/showthread.php/… – Moab Apr 17 '12 at 15:36

I solved the problem removing all the condition for starting/stopping the process...

Go to:
Control Panel -> Administrative Tools -> Task Scheduler

Task Scheduler (Local) -> Task Scheduler Library -> Microsoft -> Windows -> Defrag
Right click on the first item and Properties

And I unchecked everything

enter image description here

Hope this helps someone :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.