1

I recently noticed that when I try printing anything from IE, it simply prints out a single, blank page.
With the exception of the browser (not the page) header and footer - e.g. title, page # and URL, by default - the output is irrelevant of the actual page. Just one, blank page.

For a while, I thought it was a problem with my printer driver - I was printing to a PDF redirect virtual printer driver, and I did update it a while back. However, this occurs regardless of the selected printer, and in fact the page is blank even in the Print Preview. So, it's definitely coming out of IE empty...

Also, other programs - such as Word, VS, etc - and other browsers - I tried printing in Chrome and FF - all printed without a problem. just IE only.

FWIW, this is IE9 on Win7, both fully updated.


Update: I tried printing to the XPS file driver.
I got a script error, Permission denied on res://ieframe.dll/preview.js. Apparently, it is the print preview that is mucking up all printing from IE. Any way to tweak that?

4
  • Have you tried another browser? Apr 17, 2012 at 14:35
  • @DanielAndersson yes, and other programs.... IE is the only one (as far as I can tell) that doesnt print. IE only.
    – AviD
    Apr 17, 2012 at 15:02
  • Is it the content of that page? For example, www.google.com should be ok, but some other page that has a print css media tag disabled might not work. Just an idea to isolate where the problem is.
    – jdh
    Apr 17, 2012 at 15:34
  • @jdh thanks, but I did try many different sites. www.google.com happened to be one of them :)
    – AviD
    Apr 17, 2012 at 15:34

1 Answer 1

0

Somehow I managed to fix this problem myself - or at least, made the problem go away for now.
After getting a Permission Denied error on the print preview, I started IE in Admin mode (i.e. Run as Administrator). That seemed to work out the kinks that were bothering the preview script, as not only did the Admin IE succeed in printing, after I closed the window, all other open IE windows now print without a problem.
Remains to be seen if the solution will persist post-reboot.... Also, I have no idea what caused the problem in the first place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.