The wireless adapter (Broadcom 802.11n Network Adapter) of my Lenovo S10-3 is being detected correctly in the device manager in Windows, but I am unable to detect any wireless signals. This happened after my laptop hibernated, and it doesn't work even after rebooting the system.

The problem exists in both Windows and Linux (Live CD). It had been working in both operating systems before.

How can I find out what the problem is and reactivate the adapter?

  • Which operating system? – Daniel Andersson Apr 18 '12 at 10:34
  • Windows. Also tried it on Linux via a LiveCD, it's not working. – 0xab3d Apr 18 '12 at 10:35
  • Does a reboot solve it? It sounds like it doesn't, but be as clear as possible in the question so people can use their time to try and figure out what is wrong instead of assuming. – Daniel Andersson Apr 18 '12 at 10:36
  • Yeah I tried but no luck. – 0xab3d Apr 18 '12 at 10:41
  • Have it worked in Linux out-of-the-box before? – Daniel Andersson Apr 18 '12 at 10:45

Is there a hardware switch to turn the radio on & off on the laptop somewhere? Or maybe a Fn key combo to enable/disable the wireless. A hardware type switch really is the only thing that could affect both OS's, short of complete device failure, but you'd likely get a message/warning about that.

On my laptops, both have a physical switch/button to enable/disable the wireless, AND a Fn-key combo to do the same. My gateway's switch was on the side and I kept bumping it, turning off the radio unexpectedly. It got superglued in the ON position shortly afterwards.

Look for a slide type switch on the sides or front lip of the laptop, or maybe a button on the space between keyboard and screen (as on my compaq laptop).

  • Yeah it has. I tried before but no lock, I even tried the Fn key along with the Wireless icon button "F5" in my case. No luck at all, even I went to the BIOS settings and disabled the radio signals and re-enabled them, but yet no luck. I am wondering, even if the card is completely damaged, how come can the Device Manager in Windows detects the card, and it states that it's "working properly". I think Microsoft needs to redefine the "working properly" word!!! – 0xab3d Apr 20 '12 at 13:59
  • I installed the Energy Management. It's working now. Thanks. – 0xab3d Apr 27 '12 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.