My university gives me an internet connection by Ethernet, DHCP but they have installed MAC Filtering to allow only using my PC.

I have a wireless router TL-WR340GD. which has MAC address cloning option. but even if I clone to my PC's MAC Address it does not share internet and only my PC can access internet via it (that has same MAC).

The Configuration that does NOT work:

iPod══╗   ┌────────────┐
      ╚═══╡            │
iPad══════╡ TL-WR340GD ╞═══University Internet
      ╔═══╡            │
 PC═══╝   └────────────┘ 

I can ping the university default gateway from ipad, but cannot ping any internet DNS.

The configuration that works:

Clients===> Windows 7 host (Connectify.me) ====> University Internet

The connectify.me software works like a charm and enables me to share internet connection, by setting up an adhoc internet connection in my laptop, where other hosts can connect. The software only works in Windows 7 OS.

Now my question is, how can I set up iptables in linux, so that it can work the same as connectify.me?

I tried https://help.ubuntu.com/community/Internet/ConnectionSharing page, and followed the steps for linux ipaddress.

Clients===> Ubuntu host (iptables) ====> University Internet

in my networking setup, clients can ping the ethernet card connected to the internet, ping the university default gateway, but cannot ping the DNS servers (

Is there a chance that the ip rerouting is not updating the MAC address of the packets? Also can any one help me write the correct set of rules? Or is it not possible to do in ubuntu like windows 7?

Thanks in advance.

(P.S. a related question was asked by me here)

  • it would be good to see the iptables rules you are using at the moment. What does iptables -L output? Additionally this gentoo home router guide might help, although there might be some differences to ubuntu: gentoo.org/doc/en/home-router-howto.xml – Baarn Apr 19 '12 at 17:43
  • Wow, my iptables is completely blank :( Chain INPUT (policy ACCEPT) target prot opt source destination Chain FORWARD (policy ACCEPT) target prot opt source destination Chain OUTPUT (policy ACCEPT) target prot opt source destination I can share internet using squid3, but have no provision of setting proxy in my Android Phone. Any way of fooling my phone into believing that it is directly connected to internet without proxy? – user128952 Apr 20 '12 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.