I get this message "Your USB Composite Device can perform faster...". I am sure that both the device and the USB is USB 2.0 (by testing using another USB 2.0 device into the very same port,...), why this could happen?

As shown in the picture, my USB Composite Device already plugged to a bold Hub, and also the word "Enhanced" indicates it already plugged to a USB 2.0 port.

  • Maybe it's a USB 3 device? – Daniel Beck Apr 20 '12 at 8:34
  • 1
    @DanielBeck When I plug a USB 3.0 device (HDD) into a USB 2.0 port, it recommends a Super-Speed port. Hi-speed refers to USB 2.0... – Bob Apr 20 '12 at 8:41
  • @Bob Right, didn't see that part of the message in the screenshot. – Daniel Beck Apr 20 '12 at 8:43

Is the physical USB port that you are plugged into soldered directly onto the motherboard, or is it connected via a cable... as all Case Front USB ports are? It is completely possible that the device is USB 2.0, and the header on the motherboard is USB 2.0, but that the port or wiring for the port connected to the header is NOT USB 2.0.

Of course, this is a relatively specific situation, but we don't know the specific details of your situation. There is even the potential that the issue is the cable between the port and the device.

  • Except that USB 1.0 and USB 2.0 have the exact same connectors/cables. There's no wiring difference between them. That's why you can use pre-USB 2.0 cases and USB expansion slots with a USB 2.0 motherboard. – Lèse majesté Apr 20 '12 at 16:18
  • USB 1.0 and 1.1 standards were that cable shielding was optional, while with USB 2.0 shielding was standard. That said, most cables are made with proper ground shielding. This is not to say that the person doesn't have a cheap cable that doesn't have the proper shielding. Pre and Post 2.0 external USB ports are supposed to be the same, but this does not prove out in practice, even with dependable case manufacturers like Antec. You are correct that you can use some pre USB 2.0 cables with a 2.0 motherboard, but not all pre USB 2.0 cables. – Bon Gart Apr 20 '12 at 16:35
  • Thanks, even when I connect directly onto the motherboard it's still the same. The cable I used is original cable and it should support USB 2.0 also. Any other ideas might help. – longbkit Apr 23 '12 at 3:44
  • Hi, I found the answer. Actually it is my device tried to set working in full-speed mode, and it seems that Windows misunderstand the situation that the host controller does not support USB 2.0 High-speed mode. After re-program the device (embedded code) and let it work as default, then it can negotiate high-speed and the message disappear magically! Thanks everyone! – longbkit Apr 24 '12 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.