I have a perplexing issue with a Windows Server 2003 machine. When I connect to it (via VPN) from my home laptop (Windows 7 Home Premium, 64-bit), it's unusably slow. However, when I connect to it (using the same Internet connection and VPN) from my work laptop (Windows XP Pro SP3, 32-bit), it's perfectly fine.

I've fiddled with all the boxes in the Remote Desktop connection setup's "Experience" tab, but haven't had any luck in tracking down what's causing the issue.

What's even curiouser is that I can use my home laptop to Remote Desktop into over a dozen other Win2K3 servers (some running the same services as the target machine, though on older hardware) on the same subnet as the machine in question, and they're perfectly fine.

I can even Remote Desktop into one of the good servers on the network and then Remote Desktop into the target server from there, and it's perfectly fine.

I've turned off all graphics enhancements and sounds in the target server (and on my laptops), but no luck.

I don't seem to be dropping any packets when I ping to/from the target server from/to my home laptop. I've tried with firewalls off on both machines, and no anti-malware software running.

There doesn't seem to be a resource issue on the server - its 8 cores are mostly idle, and it's got plenty of RAM. The Event Log is clean. There's no suspicious looking processes running.

I also recently switched home laptops - the old one was Windows 7 32-bit Home Premium. It had the same problem. Is there something weird with connecting Win7 machines to Win2K3 machines - and if so, why just to the one machine?

Any ideas on how to solve would be appreciated.

  • I use on a everyday basis some win7 workstations to connect to win2k3 servers without any problem. This won't resolve your problem, but you can consider this is not this kind of incompatibility. – Gregory MOUSSAT Apr 22 '12 at 12:56
  • I do also - see my details above. It's just one Win2K3 machine that has a problem. – bbayles Apr 22 '12 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.