I have a home server running Fedora 12 and decided to upgrade to Fedora 14. I ran through the upgrade process using preupgrade with instructions from here. I ran into an issue withi insufficient space n my /boot partition and followed the instructions from the troubleshooting section that allows the upgrade to download img files during the upgrade. The last I saw my machine, it was happily downloading the img file.

When I cam back a few hours later, I have a system that will no longer boot. I'm not a complete n00b, so I downloaded and booted from sysrescueCD.

It appears the /boot partition is still in place, and still has the Fedora 12 kernels; the grub menu.lst appears coherent (I've not looked at one before as I've used Slackware & lilo mostly).

Seems like trying to reload the MBR might make sense, but I'm at a loss as to how to troubleshoot and procede.


I fixed it this way. I downloaded for Fedora 14 install media. I ran through the installation and told it to upgrade the existing install. I had it reconfigure the boot loader during install. All appears well


Format the drive and re-install Fedora. That's what I would do. Re-sizing/creating or deleting partitions will prevent future problems.

  • I have a fair amount of configuration in this installation that I'd rather not lose as yet. My data is safe, but not the config info – uSlackr Apr 21 '12 at 14:50
  • 1
    @uSlackr Ok then make the previous OS functional since you got the files. Then try to upgrade again. Using a live CD you can reload the MBR. – Kwang Apr 21 '12 at 15:01
  • exactly - its the how that eludes me... – uSlackr Apr 21 '12 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.